[RMX] Harmonizer incompatible with finer Grid Step/Subdivision settings

Harmonizer snaps BCPs onto full unit positions, even when Grid Step and Subdivision is set up for a finer grid in File > Font Info > Other Settings. This breaks smooth connections.

Screencast: http://quick.as/XGz8s8Vx (10sec)

Good point, I need to improve this. Also, when a coarser grid is selected then RMX should round to these values.