[RMX] Scaler: Not applying to all selected glyphs

So, few glyphs selected… with their inner components also opened in the selection, the scaler is not increasing the weight for all of them for some reason… I spent more than a year trying to get it to work or to understand it but finally decided to see if anyone else knows anything about this !?

Why isn’t the Scaler working?
And why isn’t weight increasing explained in their tutorial?

And also what is this… I didn’t ask it to scale all masters… I want it to apply on the master i’m viewing and editing now… but let’s focus on the first problem above!

@TimAhrens … May you please explain how is the scaler thinking or why is it not easy to understand… or what should the user do?

  1. Do they all have compatible shapes in all masters?
  2. Do you have standard stems set in all masters? (See Font Info > Masters)

1- yes
2- yes

I have for example (BehDotless-ar.medi.001) and that is a very different shapes than the usual BehDotless-ar.medi, The scaler insists on either:

1- Use the normal BehDotless-ar.medi as a source (Not the right shape) so no use.
2- Use it without a source shape but only scale width and height and No weight increasing applies… so no use.

Half of my font are duplicated shapes of the same glyph (.001 .002 .003 and so) that are contextually substituted…

The source thing needs to be explained… I don’t get it yet… What is the source of what?

Bandar, maybe you could send me a .glyphs file so I can better understand why the Scaler is not giving the expected results? The error message suggests that some glyphs do not have compatible contours.

Generally, using the RMX Scaler on glyphs that contain components is a bit difficult for he tool. I’d recommend to scale only the glyphs that contain contours.


I was wondering if this got resolved as I am having the same problem at the moment with an Arabic typeface.
I have initially 3 masters but I have also tried RMX Scaler with 2 masters and it’s still not working. I have also tried to scale only original contours but I get the same error message: not all masters in all glyphs could be scaled.

RMX Scaler is working on another file (Latin font)

Thank you,