[RMX Tools] Deactivate it on certain Masters

I just finished the Roman of a new typeface and want to start working on the Italic. I will use the same Glyphsfile for that, to make sure it will become variable. So far, so good.

For the design of the italics I often use RMX Tools to generate the dnoms, small caps, etc. As the Roman is done, I don’t want RMX Tools to generate the Romans again, as I did some adjustments there. Right now, the workaround is to copy the glyph, use RMX Tools to generate the italic and copy the paths back into the original glyph.

Is there a better workaround? Can I somehow deactivate the RMX Tools for the Romans? Or can I look Masters, that there are no edits possible?


Can’t you just set the values to the default (100%/100%, 0 weight/italic, etc) for the Roman masters?

Right now, generating only some masters is not possible. I am planning to allow this in the future, tough.

Instead of copying the glyphs you may want to copy the entire file, then generate the glyphs in the temp file, then copy things across.

Thanks, I am looking for the upgrade.

For me, it would be sufficient just to have a checkbox above the input values. Once you uncheck the box, the master won’t be generated new.