RMX Tools (Tuner and Scaler) Crashing Glyphs (1267)

I’ve experienced crashes trying to use the Tuner and Scaler, sent a couple error reports along. Let me know if you need more specifics cc: @TimAhrens Running OS 10.14.6

I’m now on 2.6.2 (1268) and the RMX tools are still crashing Glyphs, here’s what seems like relevant report info @TimAhrens

Application Specific Information: Performing @selector(runFilter:) from sender NSMenuItem 0x6000023d6700 Assertion failed: (node.is_finite()), function dekink_tangents, file /Users/Tim/Dropbox/JAF-Tim/RMXsource/RMXGlyphsCode/../remix/RMXcontour(roundings).cpp, line 47

Hello Dave,
Thank you for reporting this. Could you send me the .glyphs file that causes this crash? Then I can have a closer look myself.

Thanks for sending the .glyphs file.

It seems you are using an older version of RMX (probably 1.1.3). The bug is fixed in the current version, which you can download from https://remix-tools.com/glyphsapp/update/full

Btw, @DaveBailey, did you have “Automatically check for updates” in Preferences > Addons > Plugins active?

Is this feature really workig, @GeorgSeifert? I just tried and Glyphs did not give me any notification even though the installed RMX version was outdated (the button “Check for updates” worked, however).

In the last few weeks I was a bit surprised how many users seem to be using outdated RMX versions. Have they all deactivated “Automatically check for updates” for plug-ins?

How do I check the version of my RMX tools?

  • If you only want to check whether you have the most recent version, go to Preferences > Addons > Plugins, select Font Remix Tools, then click on Check for updates.

  • To check which version you have, you can right-click Font Remix Tools in that dialog, and choose Show in Finder. Then, with RMX.glyphsFilter selected, press Cmd-I and look for the Version info.

@GeorgSeifert I just installed an outdated version of RMX (by double-clicking the .glyphsFilter file), and got no notification by Glyphs that a newer version was available. And not notification after I re-started Glyphs.

Wouldn’t the installation be a perfect time to (unconditionally) check for and point out available updates?

Correct, I never received an update notification even with the setting enabled. Thanks for the info @TimAhrens!

@GeorgSeifert Could it be that “Automatically check for updates” has been completely broken for a long time already? It does not seem to be working at all. I really cannot get it to work, even though I have intentionally installed an outdated RMX version a few days ago.