Scaled component not aligning to integer units

Can the “Round Coordinates” option also act on scaled components and slightly scale them to round and put their coordinates and corner points on the closest integer units?

Otherwise it is almost impossible to properly align scaled components!

I need that as we speak…

Can you post a bigger cutout from the glyph. It might be easier to get that to work with corner components.

Yes the idea is close to Corner Components, but i don’t need a right-corner part and a left-corner part, all i need is one component for the tops and bottoms of many glyphs, that i may change all together at any point in the design process…

The width of these parts will vary between glyphs for mon0-line optical correction…

This is what cap components are meant for :wink:


Another screenshot:

Any special tutorial for Cap Components? the “Corner components” tutorial seems hard already!

also, why don’t “Round Coordinates” just work on components as the user actually expected it to work?

For best results, this works best with fixed widths of stems. Tutorials will follow.

The above from the glyphs site on Cap components

Cap components not good for me then :frowning:

I can write a mini tutorial for you:

  • add a glyph called _cap.cut.
  • add a shape like in the above screenshot.
  • select the two top points in a stem.
  • right click and select “Add Corner”
  • select the corner and check the “fit” checkbox in the info box.
  • maybe adjust the vertical scaling according to the (automatic) horizontal scale.

This is only relevant for caps that extend to the left and right.

You mean Path > Round Coordinates should round component scalings? One problem I see is that other than at multiples of 100%, there will be plenty of situations where at least one point will end up off the grid.

I think he meant that the nodes in the components are automatically rounded to the grid after the sailing (like it would appear after decomposing). I need to think about this.

I’ll try that, thanks!

Yes exactly!

Cap component is giving me strange results!
Path direction is unified… played with the fit options, no luck!

What i got

What i needed

Can you post a screenshot of the cap? You have to do it exactly as I showed it. The path has to sit at the origin point.

This is not the origin point.

  1. Turn your cap outline 180 degrees.
  2. Select all.
  3. Set the transformation origin (in the grey info box) to bottom left.
  4. Set its position to x,y=0,0 (also in the grey info box).

Now you moved it to the origin point.

Allah bless you!

It is working now