Scripts and plugins don't work or make Glyphs 3.2 crash

It’s all day long I cannot make almost any plugin or script work with Glyphs 3.2. I tried to reset the whole Scripts library, reinstall modules and do more simple things such as restarting Glyphs or the computer.
In a first moment every time I was running a script or plugin it was just crashing; after resetting it’s ignoring them, like if I hadn’t them installed.
I have the feeling the solution might be really easy, can somebody guide me through?

1 Like

Can you run


In the macro window?

If not, your python installation is maybe bad? Does it work in 3.1?

Hi Georg, no when I run it, nothing pops up.

If I try to reinstall Python from the Plugin manager it says:

Failed to clone repository from schriftgestalt/
GlyphsPythonPlugin to
/Users/c*********o/Library/ Application Support/Glyphs 3/
Repositories/ GlyphsPythonPlugin

So maybe that’s why; do you know how to address it?
I also don’t know how to switch from 3.2 to 3.1, should I re-install Glyphs?
Thanks very much :slight_smile:

Please go to the Repositories folder and remove the GlyphsPython folder. Then reinstall it from the plugin manager.

Hi there, same for me, I have never been able to install Python nor any script (SpeedPunk etc)
I run the command “Install Python script”, Glyph creates the folders but nothing into it. And in preferences > Complementary modules no python version is visible. And I removed several times everything in repository folder

@sergepaulus What version of Glyphs and macOS do you have?

Ventura 13.2.1 - Glyphs 3.2 - beta on

Have you cleaned the Repositories folder?

yes, many times.

And what do you have in Preference > Addons > Python Version?

And do you get error messages in the Macro window?

3 posts were split to a new topic: Glyphs Crashes a lot

That’s when Glyphs tells me it’s not able to clone the repository.
How can I move forward?

Can you normally access github from the browser? Maybe this helps: Cannot download or update Glyphs? | Glyphs

Sorry, I was waiting for a notification and then forgot to come here. In Preference > Addons > Python version there is nothing, as I cannot install Python.

Can you install python from Glyphs 3.2 supports python 3.8–3.12 (3.1 only up to 3.10).
In that python, install pyobjc with pip3 install pyobjc. That should then show up in Preference > Addons. Select it and restart.

1 Like

You did it! Thanks a lot.
(Happily I did know that pip3 etc refer to terminal, be careful, not anyone knows those things :wink: