Scripts don't appear in the script menu

Have a problem with scripts. They don’t appear in scripts menu. When I open ‘Scripts Folder’ (~/Library/Application Support/Glyphs/Scripts) from the script menu scripts are there, but after reloading (cmd-opt-shift-Y) they don’t appear in the menu.
I’ve got the latest version of Glyphs. I’ve tried to redownload and reinstall Glyphs, even have installed cutting edge version 2.1.1(782) but scripts still don’t appear.
OS X Yosemite 10.10.4
Any clues about that?

Are you sure you placed the .py files there? Which scripts?

Yes, for sure. Files placed in the folder which opens when I choose ‘Open scripts folder’ item from the Script menu.
These scripts
But actually I’ve tried many others scripts and they don’t appear as well.
It seems that Glyphs somehow doesn’t see that folder and its content

The menu command opens the application support folder and shows the script folder. You need to put the scripts in the folder ‘Scripts’.

files are exactly in the scripts folder, please see screenshot

I cannot open the link. You can just drag screenshots into the posting.

the screenshot shows that it is alright.

Did you Restart Glyphs?

Yes, I restarted Glyphs, restarted computer, redownloaded and reinstalled Glyphs but scripts still don’t appear in the menu. May be there is something wrong with my computer since it works well in others people’s computers.

I’ve noticed that there are several ‘Application Support’ folders. Each user catalog contains it here Macintosh HD/Users/username/Library/Application Support and also root directory has its own Library and Application Support folders here Macintosh HD/Library/Application Support.
When I open scripts folder from the script menu it shows this location Macintosh HD/Users/username/Library/Application Support/Glyphs/Scripts
I decided to try to place scripts folder in the root Library directory, not the users one (Macintosh HD/Library/Application Support/Glyphs/Scripts)
After that scripts eventually appeared in the script menu but only when I switch to Guest user.
What interesting is that when I choose ‘Open scripts folder’ in the script menu in the Guest user it shows me this empty folder Macintosh HD/Users/Guest/Library/Application Support/Glyphs/Scripts
So it looks like Glyphs expects scripts to be in the root Library folder not the user one which opens from menu.
When I log in with my username and password scripts still don’t work.

Glyphs looks in various places but mostly in the uses Macintosh HD/Users/username/Library/Application Support/Glyphs/Scripts If that is not working correctly, there is something wrong with your user settings. Can you check the file permissions of the Glyphs folder and the Scripts folder. It should look like this:
(with your username).

A new script I added wasn’t showing up.

It was because the MenuTitle was missing from the hashed out first line of a newly added script.

Might I suggest the it uses the filename if the menu title is missing.

Not sure, because some scripts are not supposed to show up.

Makes sense.

Hey I have this problem.

  • scripts have #MenuTitle
  • Place in correct folder
  • Permissions are ok

Note: older scripts are in the menu!

Question: are the scripts checked before appear in the menu? Like if an import something is missing?

Did you reload the scripts? Hold down the Opt key and run Script > Reload Scripts (Cmd-Opt-Shift-Y).

Hi there!

I have the same problem as Tortuga. I saved scripts in the Scripts folder but they don’t show up in the Script Menu in Glyphs, even after restarting Glyphs and my computer. I also checked the file permissions of the Glyphs and Scripts folder and I have the permission to Read & Write.

  1. which plug-ins do you have installed?
  2. any relevant messages at startup in the console or the macro window?
  3. which scripts? Can you try adding them one by one, and reloading the menu each time? Perhaps one script is the culprit.
  4. which exact folder did you place them in?
  1. I deleted and reinstalled Glyphs and I haven’t added any plug-ins yet.
  2. nothing
  3. I only added one script after reinstalling, but it doesn’t show up even after restarting Glyphs and reloading scripts. Before I had three and none of them showed.
  4. It’s the folder that shows up when I click on “Open Scripts Folder”

Can you check if the .py file is OK? It should at least appear in the menu.

For OTVar player to not only appear in the menu but actually work, you will also need the modules (click the button in Preferences > Addons > Modules)