Setting up Regular and Italic Masters in same .glyphs file?


I’m trying to add Italics to my Uprights and intuitively added two more Masters into the same glyphs file (screenshots). I made a test-Italic character afterwards but the Instance preview goes wrong. It seems to interpolate between Light-Upright to Light-Italic (I end up at about 6°), instead of Light-Italic to Bold-Italic.

I couldn’t find a tutorial about a Upright-MM-Italic workflow. Is it perhaps completely wrong to keep Upright and Italics in the same file? I thought I had seen a screenshot like that somewhere …


You need to assign a slant angles as a custom interpolation parameter. Also, unless you are planning to interpolate an intermediate slant, don’t put roman and italics in the same file. It’s only going to make things more complicated than they need to be.

This was discussed here: Should Italics and Romans be in a single Glyphs file?