Several 'No base glyphs' issues due to no dotlessi (now idotless)

Hi, so several glyphs which are generated with idotless seem to be trying to refer to dotlessi. But as this glyph cannot be created (when I try to create a dotlessi, it changes its name to the new idotless). So I get ‘no base glyphs’ issues on these.
Thanks for any tips!

Reattach your link and anchor to new named glyph

Where did those components came from?

Thanks for the replies! I think I’m maybe too much of a beginner to fully understand both answers.

@GeorgSeifert – Not sure if this helps but I am trying to generate icircumflex, idieresis, imacron, and iogonek. The dotless i exists (as idotless) but is displayed as missing in these glyphs. Each of them seem to be “looking for” dotlessi.

What I meant is: how did you produce those components?

In most cases you should be fine by just running “Glyph > Create Composite” in those glyphs (e.g. imacron).

Ah ok. I generated them under language, in this case Pinyin. I can add a component (idotless) and it shows, but it still displays the no base glyph error triangle.

Select them and choose Glyph > Create Composite. The composites will be rebuilt with the default recipe, and that will pick idotless as the base glyph.

While you’re at it, uncheck File > Font Info > Other > Use Custom Naming. then select all glyphs in your font and choose Glyph > Update Glyph Info.

Thanks a lot! It seems like I don’t have these options though, but perhaps Make component glyph does the same? It seems to work. The version of my glyphs is Version 2.6.5 (1342)