Shortcuts not working in text mode, Kern On failing

Hi Forum,

Since yesterday Glyphs has started to get a bit unreliable. I stumbled across different problems:

  1. All of a sudden shortcuts for spacing, kerning and changing masters don’t work. I’ve tried troubleshooting this in several ways, checked my keyboard settings and system preferences, checked that kerning-only mode was disabled, restarted Glyphs without plugins etc. Nothing works.

  2. KernOn is now unusable, when accessing the models it only shows a list of “slash” + [second character in chosen model], like this: /o /H /V /A etc. I tried it with different font files, same results.

I’ve updated both glyphs and the plugin, with no luck. Any reason why ths could be happening? Any solution?

Thanks in advance!

The shortcuts for spacing, kerning and changing masters no longer working is something multiple people have reported for the current cutting edge release. You can download the latest stable release from the Glyphs website and use that instead of the cutting edge release.

For fixing the keyboard issues, it would be helpful if you could send us the console output as described here:

1 Like

This solved both problems, thank you <3