Smart Components: Automatic Alignment


I followed the tutorial to add some Smart Comps to my file. Basically I got the same setup with the connect anchors as described there. The stem has got the connect anchor, the bow (or shoulder) is equipped with the _connect anchor. In the glyph where they both come together with Automatic Alignment turned on, the RSB is calculated by the stem. Hence the glyph is waaaay too narrow. What’s wrong here?


You would disable auto alignment of the first smart component (the stem in your case, I believe), or use #exit and #entry anchors.


Disabling the first one doesn’t help, unfortunately. I’ll try to go for the #exit and #entry anchors then. Hope there will be no conflicts with other components then.


Can you send me the file to res at…?



BTW: Is it somehow possible to display the Diacritics Cloud when selecting anchors in a (smart) component? Via cmd+opt+i I assign a certain script to the components, which apparently is not enough instruction for Glyphs. With rebuilding glyphs no into Smart Components I totally loose the visual feedback. (I think this should be possible without a custom XML).

PS: »Info for selection« would be incredibly useful if it would be accessible from an Edit Tab and not only Font View, wouldn’t it? I mean to get the Parameters for the glyph, e.g. when the caret is in front of one (or text is selected). Currently it gets greyed out exactly then.


You would need to add the marks to the entry for the smart glyph in the GlyphData XML.


I expected that. I want to get along without customising as far as possible. Wouldn’t it be just a consistent behaviour to recognise it by belonging to the same script?


What is the way to do this now?
I had my files setup with connect and _connect anchors, and letters composed from smart components only.
The first component had disabled automatic alignment and this way the components were connected and positioned and i could freely change the sidebearings. Now it doesn’t work and i the width is inherited from the first component. Is #entry #exit the way to go now?


Without seeing your compound, it is hard to say. Entry and exit anchors are great for using the sidebearings of the outermost components.


Hi Erich,

I’m having a similar problem. Whenever I create ‘_connect’ anchors the composite /n takes the advance width of _part.nStem and ignores the advance width of _part.shoulder. Both parts are outlines. Both /n and /m glyphs are made of two and three components respectively.

When I use the ‘entry’ and ‘exit’ I the advance widths add together and the anchors _part.shoulder connects nicely with itself but still not to the _part.nStem. Shown below. In the Arabic tutorial these anchors seem to only be used with composite glyphs as opposed to outlines. Combining both ‘_connect’ and ‘entry/exit’ anchors don’t work and it reverts back to the single advance width. Any Ideas?



The “_connect” anchors are supposed to ignore the width of the linked components.
How does the shoulder glyph look? Can you send me the file?


Hi Georg,

I can’t send you the file, unfortunately.

#1 Shows ‘_connect’ anchors on ‘part.shoulder.n’. #2 Shows composite /n glyph with incorrect auto-spacing. #3 Show mis-alignment with use of ‘entry/exit’ anchors.

  1. The stem should have an exit.
  2. entry and exit are the wrong way around in the shoulder.


Perfect. Thank you.