Smart components (diacritics) in 751 build

After installing the last update smart components just do not want to work at all.

I’ve noticed you’ve mentioned in the description to the update “I’m working on the Smart components and it might not work as expected at the Moment. So if you rely on smart components, please don’t update to that version”… but it was too late, the update was already installed :confused:

Any chance to downgrade it to 747 build (i believe it stopped working after the previous update actually) or any news on when the new update fixing this issue will be available?

The previous version should be in the trash.

It is there but… it has the same issue - smart components do not work :frowning:
That’s exactly the reason why I asked about 747 build (the feature might have worked properly there)

Update: I have found 736 build in the Trash but this version seems to have the same issue. Probably it is not problem but the GlyphData.xml one?

Update #2: Just opened the GlyphData.xml and it doesn’t seem to be the original file but the one I made changes to. That’s weird because I recall that there were two different files few month ago - the original one and the modified one. Is there any secret place where the original one may be stored?
I do not make changes to the file often - can remember if it should be in the same dir or another…

The smart components have nothing to do with the glyphData. Can you describe what your smart components are supposed to do?

If you have a custom glyphData file, it should only contain the entries that you defined/changed. Otherwise you miss bug fixes and it takes longer to launch the app.

I may be wrong with the naming :confused: All I need to do is generate diacritics letters automatically - just as it is normally done in Glyphs. This feature, as far I as remember, is definitely using glyphsdata.xml and i can’t find the original file, it’s disappeared :frowning:
And yes, the custom GlyphsData contains only the entries I’ve added, nothing else.

Update :slight_smile: Found the original file but building diacritics does not work

Just to give more information: all marks are set up (*comb and simple ones), all glyphs & marks have the anchors. But neither adding a diacritic letter or using Make component glyph does not work properly. It does work somehow - the letter is added, the mark is added but they are not aligned and the Automatic alignment for the glyph do not work either.

Finally, the issue is solved. Had to reinstall the app (no luck), remove the custom GlyphData file (still no luck), copy all glyphs to a brand new file (it works!). No idea what exactly was causing the problem though…

Maybe the file had the automatic alignment disabled in Font Info > other settings?

Hahaha - TRUE :smile: Oh my… stupid me
Thank you, Georg!