Smart filters and not-set color labels

The not-set color label (white) doesn’t behave properly in smart filters. For instance, if I set the color to red and then unset it (make it white) Glyphs treats it as if it still has a color label. In the image below, the white glyphs shouldn’t be included in the filter.

<img src="/uploads/default/original/2X/5/5dbbd0576f80045a1d140627ea8ae88d0b2c724f.png" width=“690” height="208”>

2.3b (874)

I fixed it.

Is it possible to add entries as OR statement? Like making a Smart Filter:

»Pay Attention«
Color Label > is > Red
Color Label > is > Orange
Color Label > is > Yellow

As a result, all these colors are filtered to show.

There is this option already:

However, the Any/All/None bar only appears for me if I add the smart filter then restart Glyphs. Maybe a bug?

Oh I see!

Yes, or it appears when holding the alt key instead of the plus symbol. Nice to know :slight_smile: Thank you!

Hi there, I have the newest Glyphs version and I have the same problem as “harbortype” described. I can not unset color to white.

I can’t reproduce it. You need to select another filter and then select the filter again. The glyphs are not re-filtered when you change a property.

Hmm, but can be the glyph color somehow locked? I can not change this half orange part. If I want to use other color it aplies just to the half, and second half stays orange.

That’s the layer color. If you press and hold the Option key before selecting a color, you can change the layer color.

Oh, thank you a lot!