Software would suddenly quit at anytime without any crash reports

Just started using Glyph 3.0.4 (3108) and not very familiar with this software. But it will suddenly quit at anytime when I was using or just leave it there on the screen, and it won’t show any bug report after it crashed. Sometimes it quited very soon (like 4-5 min) after I opened it, I have no clue at all.

I tried to reinstall the software and license again and did not help. Read that disabled the Mac OS SIP (System Integrity Protection) might let the software work, or is there any other solutions for this crash bug?

Can you update to the latest cutting edge version. You can activate it in Preferences > Updates.

Thanks for your reply and I tried, it’s already the latest version. It showed that 3.0.4 is the latest one. Which version is the latest version? Maybe 3.0.5 and I couldn’t see it because of my network ? (I’m in China)

In the Preferences window → Updates check Show cutting edge versions and click Check Now. The latest cutting edge release is 3.0.5 (3112).

@FlorianPircher I’m on 3112 and it says I’m using the latest version.

Thanks I’ll try it.

Yes, sorry! I got confused by the 5 from 3.0.5 — 3112 is the latest.

Which plug-ins do you have installed? I have had many crashes with Speed Punk recently, most likely interacting badly with another plug-in, but I could not hunt down the exact reason yet.

I got Font Tools, Python and Vanilla.

Those are modules. Do you have anything in the Plugins folder?

Nothing installed. I updated to the cutting edge 3.0.5 (3112) and the problem still exists.

I didn’t install any plug-ins.

Try this:

  1. In Finder, hold down the ⌥ Option key, open the Go menu, and choose Library.
  2. There, navigate to Application Support > Glyphs 3
  3. Rename the folder to Glyphs X.
  4. Restart your Mac with the ⇧ Shift key held down.
  5. Restart your Mac (this time without Shift).
  6. Next time you start Glyphs, go to Window > Plugin Manager, and reinstall all Modules.

Thanks, I’ll try it.