Some fractions don't print

I just discovered that oneeighth, threeeighths, fiveeighths and seveneighths, respectively 215B 215C 215D 215E don’t print. They show fine on screen (Adobe suite, TextEdit, Office etc, web etc) but I get four notdefs when I print them. I can get the shape to print typing 1/8 and activating OT fracture but not using the glyph. Other fractions print as expected

It happens on a variety of fonts, created with different versions of Glyphs. I tested it in both Indesign and TextEdit. Why is it happening?

Which glyph do you get? Is that the .notdef?

Yes, that is the .notdef for this font.

  • Tried different printer?
  • Different printer driver?
  • Tried both OTF and TTF?
1 Like

It’s OTF only. I only own one printer, but I asked a few friends and the file seems print fine for them. I updated my printer system and I still get .notdefs. I don’t know how to change printer driver, but I guess it’s good news that the file is ok.

Taking a guess: Some outdated printer drivers and PDF algorithms expect specific old glyph name scheme in CFFs. That would be a bug in those legacy softwares but speaking from experience, the maintainers of the softwares can be expected to be reluctant to fix them. Otherwise we wouldn’t run into problems like this, a quarter century after the introduction of OpenType.

  • Consider not using precomposed fractions at all but rather the freely arranged fractions with the frac feature only (just .numr and .dnom figures and fraction).
  • Consider delivering TTF only.
  • Consider different production names for the affected glyphs, but only in a pinch and if you know where the OTF is going to be used. (So potential side effects remain manageable.)

Thanks! I’ll test what happens with different production names. And it’s probably safer to remove the affected glyphs and rely on frac as you suggested.

Update: replacing the production names as @mekkablue suggested solved the problem.
For one eight I’ve tried: uni215B, one_eighth and one_fraction_eight and they all printed fine.


Hi, I’m running into the same problem here. In OTF some fractions are not being printed. I tested printing from TTF fonts and the fractions reconfigured differently in the print out (see picture). Are fractions made of separate components on TTF fonts? Couldn’t we force the same in OTF fonts?

I’m looking for a solution for the shipped fonts, without side effects. Yes I know that this is a drivers problem, but I was trying to implement an innocuous work around solution.
My worry here is that the TTF fonts are also posing a problem, because fractions come out wrong.

Many thanks.

It may have to do with Unicodes set/unset; and in AZO TTF, are you using TTF Autohint? If so, can you try without?