Some plugins do not work since update and/or since I messed everything up


#1

Hello there,

[Disclaimer : I’m quite inexperienced in python, some of the following might not use the proper taxonomy]

I’ve recently updaded my version of Glyphs and it seems some things have been broken along the way.

Speedpunk doesn’t work anymore

— I’ve double checked that I’m running the latest version of both Glyphs and Speedpunk. At some point it worked (with the Cmd + Maj + X shortcut) but it no longer does (details below)

Some Mekkablue plugins do not work anymore (especially Copy Layer to Layer, which was a life savior)

— I’ve tried to download them again, remove and replace the files in the proper libraries. But it didn’t do much.

— I’ve then tried to re-intall Python (both the last 2.7 and 3), and to reinstall all of modules through glyphs (Vanilla, and all of those…).

It is at that time that Speedpunk stopped to work — although, again, it’s been installed and appears in my library folders.

— I’ve run the command lines to check the proper installation of vanilla but it doesn’t print anything — although my library folders tell me the opposite !

— Of course all of those manipulations were done with occasionally quitting and relaunching glyphs, I also restarted my computer a couple of times.

Is there anything you can spot from where you are ?
I’m sure I did something wrong along the way but I cannot find what.

Thanks a lot !
Raphaël


#2

Copy Layer to Layer has been broken for some time. Rainer said it needed a rewrite but he was short of time at that point. It happened because of some changes in Glyphs.


#3

It should show up in the View menu. Does it not? Verify that you do not have two copies of the plug-in in the Plugins folder.

What exactly does not work? I quickly tested it and it worked for me.


#4

From what version did you update?

Installing python 2.7 is not a good idea. It collides with the system python.


#5

@mekkablue :

  1. About speedpunk, I have two files : SpeedPunk.glyphsreporter and SpeedPunk.glyphsTool. If I’m not mistaken, the only one I should need is the “Reporter” from the 1.11 version right ? Still when I open it (and therefore install it) with glyphs, nothing appears in the view menu.
  2. About Copy Layer, when I try to launch the script nothing happens. I mean the small window with “copy from XXX to XXX” doesn’t appear, nor does the “console” (is that correct word ?), as it used to.

@GeorgSeifert : maybe this is the problem then ! I read somewhere that the most recent version of phython (the 3.something) was having issues — especially with softwares running on the old version — and that it was more safe to keep python 2.7 installed. I’ll try to remove it and I’ll let you know :slight_smile:

Thanks to both of you !
Raphaël


#6

Speedpunk: Remove the .glyphsTool from your Plugins folder. Restart, and if there is nothing in the View menu (there should be Show Speed Punk at the end of the menu), take a look at the output in Window > Macro Panel.

Then there must be an error message in Window > Macro Panel.


#7

I updated Glyphs from a rather old version (I’d say, mid 2018) but no idea of which. Could that be part of the problem ?
Thanks :slight_smile:


#8

Ok so, I’ve uninstalled and re-installed Python (only the newest version, as George advised to remove the 2.7). I also removed and re-installed Vanilla, fontTools and robofab — as I understand, they are used to run some plugins and scripts.

Still, SpeedPunk doesn’t show up in the View menu.
Actually, none of the plugins are visible in this menu (show tops and down, gauge tool etc…)

And regarding Copy Layer to Layer it doesn’t trigger anything in the macro panel, it’s completely blank.

Is there something I can do ?
Many thanks


#9

Can you do:

import sys
print sys.version
import objc

in the macro panel and post the output?


#10

There have been some developments. Out of despair, I tried to reinstall the old SpeedPunk.glyphstool file, in addition to the already-installed glyphsreporter one. And all of a sudden everything got back to normal !

The Copy Layer to Layer scripts, Speedpunk and basically everything else are now working nicely.

@GeorgSeifert : something is still weird on the Macro Panel. It doesn’t seem to respond. I ran your command, but it stays blank. I’m hitting Cmd+Return without any result.


#11

Did you enable Glyphs > Preferences > User Settings > Use system console for script output?


#12

Yes I did @mekkablue


#13

If you disable it, you get the output in the macro window again.


#14

Oh, okay got it.
Here’s the output of your lines @GeorgSeifert

2.7.10 (default, Feb  7 2017, 00:08:15) 
[GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.34)]

#15

That seems to be the right version.
Do you get any error messages when you try to run the scripts or plugins?