Some scripts (like mekkablue) are not working

Hello! I’ve just downloaded Glyphs 3 (I am using El Capitan 10.11.6.) and I’m finding some problems.

Some mekkablue, Toshi, HT Letterspacer (and maybe more) scripts are not working (nothing happens), like Kink finder, Set Tool Shortcuts, Travel Tracker, Instance Slider, New Tabs with Right Groups but some other work like New Tab with Kerning Missing in Master, Remove Local Guides… I have all these modules installed and the following Python selected

Captura de pantalla 2021-06-07 a las 10.48.55

Thank you so much!

I’ve just tested those scripts, everything works for me.
Have you tried to update Glyphs 3 after installation? (Glyphs > Check for updates in top bar menu).

It says I’m up to date (Glyphs 3.0.2 is currently the newest version available) and they still don’t work…

When you run a script, see what is written in Window > Macro Panel. there must be an error message there.

Also: Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

The Macro Panel shows nothing after running the script. It’s like nothing happened.

Captura de pantalla 2021-06-07 a las 16.51.50

I already tried the latest beta version this morning and nothing changed…

Expand the log in the bottom half:

Ooopsi. This is what it shows:

Captura de pantalla 2021-06-07 a las 17.21.06

Can you switch to the latest cutting edge version (activate it in Preferences > Updates) and remove and re-install the vanilla module?

Same result…
Captura de pantalla 2021-06-07 a las 18.05.34

That is a problem of the used vanilla version with your version of macOS. You can “fix” this yourself by commenting out the parts that are not compatible. In the error message, click on the blue line File "", line 12. This will open a file in a text editor. Add a # at the beginning of line 12`
it should look like this:

#from vanilla.vanillaGridView import GridView

then search for "GridView" and add a # before it as well:


Then restart Glyphs and the scripts should work.

Awesome, thanks!!

Now the scripts work but I get this message when I open Plugin Manager (and everything is empty after I click OK:

EDIT: I think it fixed itself because now I don’t get that message anymore and Plugin Manager looks normal!

Thank you!!!

I believe this is related to the Fastly issues today.