‘Something went wrong with the remove Overlap filter'

This is so strange. My font has been working so well for ages. I keep updating it as needs expand, exporting new versions of it. But suddenly, I now cannot, it keeps giving this error:

Something went wrong with the Remove Overlap filter in glyph: three

The strange thing is:

  1. I made no change at all to glyph three. And it’s been fine in the hundreds of previous exports.
  2. I do not think there is any overlap in that glyph
  3. I tried unclicking ‘export’ on that glyph to troubleshoot - no change!
  4. I tried deleting the body of the glyph and re-drawing a simple shape - no change.
  5. I tried updating the app, from version 1352 to 1361 - no change
  6. I’m on a Mac but made no updates to my Mac.
  7. I tried selecting all glyphs (over 700 of them) and correcting all path directions and tidying paths - no change.

What I had done was make some new glyphs before this happened, which is why I was trying to export a new version. However, although glyph ‘three’ is involved with some liga glyphs, it is not involved with any of the new glyphs. Can this error message occur falsely, when the problem is actually something completely different? How am I meant to find what the problem is?

Can you send me the file (to support at this domain)?

1 Like

Thanks @GeorgSeifert . I did PM @mekkablue about this one week ago, and I tagged you in that conversation 5 days ago. I included a link to the file there, it was too large to attach to the message. I didn’t get any reply from either of you. If I tag you again will you see it? I will try right now… ok that’s done.

If you cannot see that then I should PM you directly?

I don’t see your message. Can you send it again. Or add me to the conversation?

1 Like

I had a look at the file. I cannot reproduce the Overlap Removal issue in Glyphs build 3029.

Oh ok. When I clicked update before starting this query, it updated to ‘Version 2.6.8 (1361)’. So maybe your build is newer and the issue was fixed since my version? How come my update gave me 1361? Is it because I’m using an older OS? If so, does that mean I have to instal a new OS to make it work?


I am using Glyphs 3. You appear to be using Glyphs 2, which uses a different algorithm. I sent you a few suggestions in a DM.

1 Like