Space Bar doesn't load the info boxes in the top of the screen

I installed Space Bar from the Plugins Manager, but it doesn’t show the info boxes in the top of the screen. It shows the settings in the contextual menu though.

This is the message from the macro panel:

Traceback (most recent call last):
  File "__init__.py", line 1230, in foreground
TypeError: 'TempDataProxy' object is not callable
1 Like

I fixed it.

Hm it still doesn’t work. Is this an issue from my computer? I have no idea what can cause this problem… Any ideas?

The Macro Panel spits out this error:

Traceback (most recent call last):
  File "__init__.py", line 1238, in foreground
  File "GlyphsApp/__init__.py", line 4061, in FontMaster__repr__
  File "GlyphsApp/__init__.py", line 329, in __repr__
  File "GlyphsApp/__init__.py", line 356, in __iter__
  File "GlyphsApp/__init__.py", line 1801, in values
TypeError: 'float' object is not callable

What version of Glyphs do you have?

3 of course. And loving it. :wink:

I mean exactly. The four digit starting with ‚30‘

Okay, sorry: 3.0.1 (3039)
I never use the experimental versions.

I see. I must have overlooked this from the beginning. It’s in all the versions the same. :wink:

Do you have some documentation somewhere how to set them in Glyphs 3? It’s different from the previous version.
I don’t know what ‘hStem0’ and the arrow left from it mean. :pray:
Schermafbeelding 2020-12-24 om 14.51.27

Thanks for your help.

I tried updating to the cutting edge version, but my Glyphsapp keeps crashing. I really would like to use Space Bar to finish up my font.

Is there an ETA on the release of the next Glyphsapp version? This should fix the problem and hopefully Space Bar will work again.

Thx.

The arrow indicates the type of stem:
↔︎ Vertical Stem
:arrow_up_down:︎ Horizontal Stem

The name is arbitrary. hStem0 is probably a constructed name for an unnamed stem. You can give it a name that makes sense to you, e.g. ‘LC vertical’ etc.

Can you confirm it is SpaceBar that crashes it? Keep sending the crash reports.

Hi Rainer,
Stems! Check!

I just sent a crash report. I tried updating to the cutting edge version, without any luck.
I don’t think it’s Spacebar that crashes Glyphs. It’s active, but not working. But I’ll deinstall it to be safe and will check again.

There where indeed some issues. I fixed them.

Thx George, for your help! I appreciate it. I can’t get it to work so it must be my Mac. I hope it’ll work with upcoming Glyph updates. For now I’ll finalize my font family the oldskool way. :wink:

Do you get any error messages (in the macro window). Can you remove and re-install it (maybe even manually remove the folder from the Repositories folder)?

It keeps spitting out this message and if nobody else has this issue than it’s a problem on my side. Or nobody uses Space Bar and gets the same error :joy:

Traceback (most recent call last):
  File "__init__.py", line 1216, in foreground
  File "GlyphsApp/__init__.py", line 4061, in FontMaster__repr__
  File "GlyphsApp/__init__.py", line 329, in __repr__
  File "GlyphsApp/__init__.py", line 356, in __iter__
  File "GlyphsApp/__init__.py", line 1801, in values
TypeError: 'float' object is not callable

But to be precise. Space Bar is running, it just doesn’t show the infoboxes. The settings are available. This is just not worth anything if you don’t see the visualization in the infoboxes in the top :wink:

Thanks for the error message. That is a bug in the python wrapper in version 3.0.1. It is fixed already in 3.0.2.

Ow, it’s a Python issue? I tried updating to the latest version, using this page:

But I keep getting this error (I changed some information to hide my computer and user name):

The default interactive shell is now zsh.
To update your account to use zsh, please run chsh -s /bin/zsh.
For more details, please visit https://support.apple.com/kb/HT208050.
COMPUTERNAME:~ myname$ python3 --version
xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
COMPUTERNAME:~ myname$ sudo brew install python3
Password:
sudo: brew: command not found
COMPUTERNAME:~ myname$

Do you have any tips on what to do?

PS: I’m running Catalina 10.15.7 on a mid2012 MBP

I think Georg was saying you need to update to Glyphs 3.0.2.

Oh I see now. :smiley: