Spacing is acting weird

again me about my script font. I started this project in FL. In the middle of the project I had to switch to Glyphs (G).

Since it is a script font, some elements of certain letters have to overlap perfectly to look as they should. These elements have the same width and they align really tidy in G.

When I export fonts (multiple master) the spacing is slightly off when I look at it in Indesign. The overlapping elements dont overlap as tidy as they do in G.

My assumptions: I have also noted that the spacing values have positions after the decimal point. I can’t get rid of that. G keeps putting it back in when I change that in the little info box on the bottom left. Is that a remnant from FL?

Also I didn’t have extrem points in all the places where overlapping takes place because of design concerns. Adding them doesn’t seem to help the problem …

Any ideas? Do you understand the problem, or should I post some pictures?


you may re-check the Character menu settings in Indesign.

If the result in Indesign is different than in Glyphs it is most likely a font cache problem.

If you don’t have extreme points, you end up with fractional side bearings.

Can you post screenshots from Glyphs and Indesign that show the problem?

Thanks for your replies. Its not a character menu setting issue, nor a font cache problem. I checked all that and I have deleted all adobe and system font caches.

Here are a couple of screenshots from Indesign and G. Also note that the values for the sidebearings are fractional even though the glyphs have extreme points as they should.

Thankfull for any help.

It is not visible but you probably have a italic angle set and that produces fractionally side bearings. That is purely cosmetic and does not influence the output.

About the spacing problem: What is in the other master? And if you change the the spacing in Glyphs, does it change in Indesign? And you have set to Metrics Kerning (not optical) (just to be sure)?

Ok, the italic angle solves that issue. Thanks.

The other master is a really bold one. All the instances in between look off, too. But they look like they are interpolated between the two (the problematic light one and the good looking fat one).

The spacing changes in Indesign when changed in Glyphs. And, yes Indesign is set to Metric Kerning.

I have been experiencing some crashing problems lately. Could that have to do anything with it?

Can you send me the .glyphs file?

Hi there, i have a similar problem. Some Letters are overlapping, if I check to ›optical‹ in illustrator/indesign. Thanks for your support.

link: .png?dl=0

Please read this to understand what Optical Kerning is:'s-optical-kerning.php

Thx for your the article! … that was very dewy-eyed.