Spacing Keyboard Shortcuts 'Dropping out'

I’ve had this niggly little issue for some time now, and it tends to rear it’s head once every 5-10 min during each Glyphs session. So not huge, but I definitely notice it.

Basically, I will be using Ctrl or Cmd plus my arrow keys to adjust L/R sidebearings. I haven’t been able to reliably reproduce the issue, so I’m unsure about the cause, but the shortcuts will stop working, and I get the system error ‘boop’ sound, as if the glyph I’m adjusting has lost ‘focus’, and OS X is unsure what I’m trying to achieve that with particular keyboard shortcut (and so returns the boop sound, with no action).

It happens more often when I’m doing a lot of spacing, so continual/repetitive use of these keyboard shortcuts. The fix is easy, I simply have to use my mouse and click back on the glyph I’m adjusting to regain ‘focus’. Then the shortcuts work just fine, until the next time the issue happens.

Anyone else experience this? Let me know if you need more information from me.

Thanks guys.


Are you running any plugins/filters/script while you are doing the spacing?

I do have a few plugins installed (Erode, ShowAngledHandles, SpeedPunk), but no plugin/filter/script in active use whilst spacing, no.

Have you made sure that none of the system shortcuts are interfering? Like switching the input method? Any hardware, like tablets, connected that may override some input methods?

Yup, I can’t find anything that would be interfering (shortcut conflicts, input methods etc).

I will try my best to notice anything in particular that could be be happening at the same moment I lose the shortcut. There must be something. But haven’t picked anything up yet.

Different user?

I haven’t tried this! If it helps, the problem has been occurring more or less since I started using Glyphs years ago, across various installations of OS X etc. But I will try another user profile and see if it keeps happening.


This is happening to me on glyphs 3…I wonder what I did wrong.

Make sure the shortcuts don’t collide with systemwide shortcuts on system preferences.

1 Like

Just now it started working, but then when I tried using the “ctrl”+“command” to move the glyph inside bounding box the other shortcuts dropped out again…but now if I hold “option” i can kern!

I will double check. I thought somehow apple music was messing with it but I don’t think so. Was just gettin the hang of them lol. Probably learn more from successfully trouble shooting tho…

It’s working again. I’m not sure what’s interfering but I’m glad its working :slight_smile:

I’m having this issue pop up currently only in one file. All plugins are disabled and all the glyphs are “unlocked” as best I can tell but both cmd and ctrl + arrow shortcuts don’t work.

Do you have a Sync Metrics parameter in one of the masters?