Spacing problem with ONE glyphs (on arabic font)


I have a spacing problem on InDesign with only one glyphs : reh-ar.fina (this problem isn’t present on Glyphs.
But the problem depends on what comes after the glyph

I let you watch the problem on the screenshot :

(in InDesign)

(in Glyphs) (without the issue)

Thank you :slight_smile:

There might be some bad kerning. Can you check (in LTR mode) the Kerning panel if there is anything related to that pair.

It looks like good

But I have a new problem with this glyphs : a positional shape problem with the character that follows. (it’s not the only case) (it does it all the time)
Capture d’écran 2022-01-28 à 09.52.07

If I recreate the glyphs, that could work ?

Can you send me that file?

Yes, I can send you file on ‘support’?

Yes. Send it to that address.

If it can help you, I find an other problem :

(I think it’s the same positional shape problem)

There was indeed a some kerning in the LTR kerning. Search for RTL kerning in the forum. There are some script that fix this.

About the other issue. I can’t see it in the file you send. I needed to regenerate the features as it was missing a lot glyphs. Maybe that fixed it?

So, first of all, the spacing problem is solved :slight_smile:

For the second, nothing changed.
Is it not a feature code ?
“yeh-ar.medi” should be “yeh-ar.init” no ?

Not if it follows a reh-ar.medi. That shouldn’t be there.

1 Like

ok so, the 2nd issue is solved.

But I have again this spacing problem and I don’t find the kerning in the RTL kerning or the script that fix this ? (I searched with differents keys words)

A gif to show you the problem in InDesign !
As you can see, it depends on the characters ! Is it the kerning ? Strange no ?

(sorry for spam :confused: )

Enregistrement de l’écran 2022-01-28 à 16.37.01

The wrong kerning is in the LTR mode. Search for ‘uni’

1 Like

Thank you very much, all it’s good for me ! :slight_smile:

Best :slight_smile: