Specific Glyphs file crashes

Hi everyone,

I have a problem on a specific glyphs file… I don’t understand what is happening.
In fact I noticed several bugs :

  • First, there are grey lines which appears at the baseline of my glyphs.
  • Then, when I want to click and modifiable the “f” glyphs, it crashes all the file and Glyphs disappears.

I attached here the screenshot of the message I received.
How can I resolve this problem please ?
Thank you so much !

Morgane Vantorre

Can you try starting the app without plug-ins? Hold down OPT+SHIFT at start.

1 Like

Hi, thanks for your quick reply ! Can I send you my file rather ?
Your commands don’t work here… :frowning:

Also I noticed that other glyphs don’t work : the f, u, s, x and b…
But I only verified the lower cases…

OK, but won’t get around to it until tomorrow. In the meantime, try the steps described in this tutorial:

Alright thank you so much ! How can I send you it ?
I will have a look to this link !

Send it to support at this domain. Or a dropbox (or similar) link as a direct message in the forum.

Thank you for your quick reply !
Sorry I am beginning here :slight_smile:

Hi Mekkablue, I have just sent you a private message with the file.
I hope you could help me. The problem is come from the file… Not the software.

I found the reason. The background images (scans?) placed in the background had some extreme distortions, which also caused the artefacts you saw at the baseline. For now, copy the following in Window > Macro Window and press Run:

for g in Font.glyphs:
	for l in g.layers:
		if l.backgroundImage:
print "Done."

This will reset all image transformations and then the file will not crash anymore.
We will see if we can prevent the crash in the future. Thank you for the file!

1 Like

Oh !!! Thank you so much MekkaBlue for you very quick reply and your help. I have just tried this and it works ! I am very happy to see my file is going better now. I am lightened !!
I recently moved my images files, maybe it is the source of the bug…

You’re welcome. BTW just rediscovered an old script of mine that would have already done what I pasted above: mekkablue > Images > Reset Image Transformations.

1 Like

Thanks again MekkaBlue for everything !
So, for people who would be interested by the problem : for my part it comes from an image background bug. I recently modified the x-height of my lowercases with the tool named “transform”. This one distorted all images I let in the background, at the same time. This extreme distortion seems to be the reason of the crashing… !
Here are images of what happened on my file :

-Then, when I clicked on a specific letter (especially f, n, u …), it became like “frozen”, I couldn’t do anything and a few seconds later the software crashes

Now everything is going well thanks to the code mekkablue sent me ;). ouf !

Can you reproduce the image transformation bug?

Hm yes so my goal was to make my lowercases a little bit biggest. So I selectionned all my lowercases and decided to use the tool “transform”

Then I have modified the pourcentage of the height and width of my letters. I click on “run”.

What I forgot is that I had hidden images in the background. (that I used at the very beginning of my typeface) and it seems that theses images were also impacted by the transformation I made.
Everything was good during 2-3 days and the file began to crash after.

Is it all what you want to see ? :slight_smile:

When you redo those steps, does it mess up the images again?

Yes I have just tried to reproduce it and the image background systematically follows the letter transformation.

Also, it is maybe a major information : here I reimport a new image for the test, but you have to know that before, the link of certain of my images were broken. I could see this icon :
I didn’t careful to remove them at all

Yes, only the (relative) path of the images is stored in the .glyphs file. You can relink them with the mekkablue scripts for Images.

1 Like

Yes, thanks for the advice :slight_smile: !