Speed Punk crushes

I have a problem with the plugin Speed Punk and would be grateful for helping me with it.
The plugin doesn’t appear in the View menu after installing, and when I restart Glyphs I see the message that Speed Punk was crushed. Glyphs works correctly after I close the error window.

Remove and reinstalling did not work.
I use Glyphs version 3.0.3.

Is there more info in the error window?


Can you remove and reinstall and then post the error when first restart after that?

Yes. Nothing changed.


Then go to the plugin folder and delete the plugin manually.

It didn’t help, crushed again.

Remove the plugin and restart the app. That should stop that dialog. Then install it from the plugin manager. Then there should be a different error dialog. I need that one.

At the first start after reinstall, the plugin error window didn’t appear. But the second start I see it again. And in the View panel I don’t see Show Speed Punk:

So, when you remove, restart, reinstall: You don’t get an error message? Can you check the macro window?

Yes, still no error message at the first start but only at the next. I checked the Macro window and it’s empty.

I recorded a screencast with all of my actions but I can’t attach this as I’m a new user.


I figured it out. I reinstalled all modules and then reinstalled Speed Punk. And it worked!
Thank you for your time!

1 Like