Speed punk makes glyphs quit immediately

Hi,

I just installed speed punk on glyphs v3, but the glyphs always quit immediately when I try to use it. Does anyone know how to solve it? I use Glyphs 3.0.2 (3050)

Thank you.

1 Like

Try selecting Python 3.8.2.

See this thread for details:

1 Like

I’ll have a look.

1 Like

I tried to follow what you suggested, but it’s still happening glyphs quit immediately.

1 Like

Can you check that you have the latest version of the plugin. And what python version and what MacOS do you have?

I think I’m using the latest version because I just installed it directly from the plugin manager yesterday. I’m using python 3.8.2 and macOS Mojave.

I am having a similar problem! I use 3050 and macOS Big Sur.

When I install SpeedPunk together with other plug-ins, it will cause Glyphs 3.0.2(3050) to crash, installed alone there is no problem.

What other plugin for example?

unfortunately, i have the same problem here. Glyphs3(3052) decided to crash everytime i edit with ‘speedpunk’ activated. with ‘magic remover’ installed.

with python 3.8.2(Glyphs)
Thanks!

Can you send some crash reports (the ones that show up when you restart the app). Add a note about SpeedPunk.

Hi Georg, seems like the error can’t be reproduced and Glyphs3 is running fine again after reinstalling the plugins!

I am also having issues every time I try to use speedpunk with Glyphs 3, I’ve updated to the latest version. (3.0.3, 3065). I’ve deinstalled and reinstalled the plugins several times. I have the latest python downloaded from the the module tab. It crashes almost immediately, every single time. I’ve sent probably 10-15 crash reports. I’m on OS Catalina. I’ve notice I have some updates for my OS. I’ll try installing those. Any other suggestions?

Cannot reproduce. Please keep sending the crash reports, the more the better.

Will keep sending the reports. Any more tips for troubleshooting? It’s still doing it repeatedly. It’s unusable.

I’m on Glyphs 3.02 and running with OS High Sierra (10.13.6).
If I’m lucky I can make a single adjustment using Speed Punk before crashing. I often return a crash report, but not always as it can happen so often I keep retrying.
As an alternative, I removed Speed Punk and am trying SuperTool, but the Curvature display doesn’t show. Nor does the Tunni lines. The Harmonize does seem to work.

  • Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.
  • Consider upgrading your macOS, at least to 10.14.

Do you have other plugins installed?

Hi! I do have show stem thickness and red arrows installed. They’re working just fine. I’m not trying to use multiple plug ins at once. I updated my OS yesterday to 10.15.7 and updated glyphs. should I deinstall the entire app reinstall?

Make sure you have the latest versions of those plugins (no need to reinstall the app). There was a bug in the plugins that could cause crashes. But most plugins are updated now.