Speedpunk problem

I just downloaded and installed Speedpunk and now Glyphs won’t open. (“Glyphs quit unexpectedly…”) What should I do here? Thanks.

Just to add, I’m running Glyphs version 1.4.4

Ok, so I’ve taken the plugin file out of the (hidden) plugin folder. Glyphs starts up fine. I supposed it’s a bad file?

Please update to 1.4.5. How did you unzip (third-party tool?) and install the plugin?

Just unzipped, double clicked, and it installed.

Updated, and still doesn’t open when “SpeedPunk.glyphsTool” file is in the “Plugins” folder.

Do you use the built-in system Archive tool, or are you using a third-party tool?

I just double click on the .zip file. (speedpunkglyphs_v1.0.zip)

What happens in the Console when you start Glyphs with the plugin?

6/22/15 10:22:29.965 PM Glyphs: *** Terminating app due to uncaught exception ‘OC_PythonException’, reason: ‘<type ‘exceptions.NameError’>: global name ‘GlyphsFilterOffsetCurve’ is not defined’
*** First throw call stack:
0 CoreFoundation 0x0000000101118f56 __exceptionPreprocess + 198
1 libobjc.A.dylib 0x0000000100f8cd5e objc_exception_throw + 43
2 CoreFoundation 0x00000001011a31b9 -[NSException raise] + 9
3 _objc.so 0x0000000114956150 PyObjCFFI_MakeBlockFunction + 494
4 libffi.dylib 0x000000010883e7ea ffi_closure_unix64_inner + 510
5 libffi.dylib 0x000000010883dffe ffi_closure_unix64 + 70
6/22/15 10:22:29.965 PM [0x0-0x47047].com.GeorgSeifert.Glyphs: terminate called throwing an exception
6/22/15 10:22:33.515 PM com.apple.launchd.peruser.501: ([0x0-0x47047].com.GeorgSeifert.Glyphs[543]) Job appears to have crashed: Abort trap: 6

the error message can’t be from Speedpunk but from another plugin. What else do you have installed?

Unrelated to Galen’s problem, but I report another one here. I noticed that Glyphs crashes when you are in SpeedPunk tool and go to background (command+B). I guess it might crash in some other places too. Can anybody fix this?

@Tosche I cannot reproduce this in Version 760. What happens in your console?

It makes a crash report obviously, though I don’t know which bit I’m supposed to read.

Mine is also 760 and I can reproduce the crash anytime.

the problem is in the plugin. I’ll speak with Jan to update it.

I’m away from my primary computer at the moment, but I believe I just have RMX (RMX.glyphsFilter) installed.

Just wanted to check in on this and see if I need to contact anyone else about this. Thanks.

@Galen Have you tried deactivating all plugins except Speedpunk? Perhaps the current version of RMX is not compatible anymore with the old Glyphs.

Indeed that is the problem. I’ll just have to switch out the plugins as I use them.

I suppose one of the plugins you use simply does not support glyphs 1.x anymore. I doubt it is speed punk.