SS glyphs and kerning

Hi. How do I do to kern stylistic alternates by default glyphs, for example, a.ss01 v. Ideal situation should be I can select a glyph on type mode and change the menu to stylistic alternate to change only that glyph and not all entered text. Is there any way to achive this without manually add it in kerning table?

Thanks

Does v also have .ss01 alternates? Otherwise it should be easy (just turn the feature on).

If there is a case where you absolutely need to partially use .ss01 glyphs, I would just make a kerning string with Regular Expression.

1 Like

Cmd-F and insert the stylistic set glyph.

Or what I do, activate Font Info > Other > Keep alternates…, type it and then switch to the alternate by pressing fn-right.

On a more general note, if you need to kern partial sets, it may be better to separate your stylistic set into multiple sets, i.e. move v.ss01 to v.ss02 etc.

1 Like

@Tosche yes. My font structure is like ´A´ ´A.ss01´ ´a´ ´a.ss01´ and I need to test kerning for all combination.
Using cmd-f to insert could work, but it is really tedious. I´ll try the other method @mekkablue said.

thanks guys!

I mean, if v does not have ss01 alternates, then turning on ss01 feature will automatically convert a string of /a/v into /a.ss01/v.

But really, get yourself a good plain text editor (Sublime Text, TextMate, etc) and learn regular expression. That’s way handier.

Can you guide me on regular expressions for glyphs? it´s like regular expression in JS?

Oh, I mean making kerning string outside Glyphs.

When you have a string like “AABACAD…AZA”, then you can easily make “/A.ss01/B/A.ss01/C…” and paste it back to Glyphs or its sample string (though this particular case is just search & replace).

A little script that can help :slight_smile: It can be improved.

ss=’/a.ss01’

a= '/a.ss01’
b= '/b.ss01’
c= '/c.ss01’
d= '/d.ss01’
e= '/e.ss01’
f= '/f.ss01’
g= '/g.ss01’
h= '/h.ss01’
i= '/i.ss01’
j= '/j.ss01’
k= '/k.ss01’
l= '/l.ss01’
m= '/m.ss01’
n= '/n.ss01’
o= '/o.ss01’
p= '/p.ss01’
q= '/q.ss01’
r= '/r.ss01’
s= '/s.ss01’
t= '/t.ss01’
u= '/u.ss01’
v= '/v.ss01’
w= '/w.ss01’
x= '/x.ss01’
y= '/y.ss01’
z= ‘/z.ss01’

print “%s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s %s” % (ss, a, ss, b, ss, c, ss, d, ss, e, ss, f, ss, g, ss, h, ss, i, ss, j, ss, k, ss, l, ss, m, ss, n, ss, o, ss, p, ss, q, ss, r, ss, s, ss, t, ss, u, ss, v, ss, w, ss, x, ss, y, ss, z)

1 Like

Too much reduplication. How about this:

abc = "abcdefghijklmnopqrstuvwxyz"
kernLetter = "/%s" % abc[0]
suffix = "ss01"

abcSuffixed = ["/%s.%s" % (letter,suffix) for letter in abc]
kernString = kernLetter + kernLetter.join(abcSuffixed)

print kernString
2 Likes

Much better and concise!
Thanks mekkablue!

ran this in Macro Panel without any result. I am missing something?

Make sure the output is showing, perhaps you need to drag the separator line:

so weird, got the console open as you… nothing happend, even a print “hello” doest show

Have you ‘Use console for script output’ (in preferences) set? Uncheck it.

oh, now works. Also had to restart Glyphs after uncheck it.