Steal Metrics script not working

Hello everyone,
I installed the Spacing script folder. Is everything working except for the script Steal Metrics. (vanilla is installed).
I run (Script>Spacing>Steal Metrics) and then “Paste Special” in another master, but nothing happen. Does anyone know the reason?

Thanks in advance

  • In Glyphs 3? Better install through Window > Plugin Manager > Scripts.
  • Which error message do you get in Window > Macro Panel?
  • The script has nothing to do with Paste Special.

I’m having a problem using Steal Metrics in Glyphs 3 as well. The problem I’m having is this:

IF I ATTEMPT TO USE STEAL METRICS ON MORE THAN ONE GLYPH AT A TIME, the script seems to be copying over the LSB just fine, but it’s doubling the value of the RSB, unless the RSB is calculated from another glyph in the original, in which case it copies that over fine.

IF I DO ONE GLYPH AT A TIME, it seems to work just fine.

I’ve never had this problem in the past before Glyphs 3. Anyone have any ideas?

I had the same issue.
It was related to a small bug in the app, I believe. It might have been fixed in the latest beta but I haven’t checked yet.

Running the script twice in a row worked for me.

There’s a bug that sometimes causes the metrics not to be reported correctly.