"Stems can't be zero" preventing export (build 3052)

I don’t understand the “Stems can’t be zero” error I’m getting on export.

My file was exporting fine. I tried to add a ligature glyph by copy-pasting and renaming an existing one, and something went wrong. I still don’t know what. But now even restoring to an older version of the file still gives the same error, even though it’s a version that I know exported fine just an hour ago.

new file won’t export

older file, exported before, not now

I’m not trying to do any variable interpolation here, but I am using a lot of unusual ligatures.

1 Like

The last stem in the Bold master is zero, just as the error message says.

Interesting. I wonder how/when that last stem was created. I don’t think I created it, I’m wondering if there’s a way I could have accidentally invoked something to create it automatically, since there are fewer stems than in the regular weight master.

Thanks for your help.

In my case it was because of the zero value in here:

1 Like

How did you find out what stem value to put there instead of »0«?

Have you read this: Hinting: PostScript Autohinting | Glyphs ?