Strange export problem, partial fills

Dear all
I’ve drawn the character O (“oh”, not zero :), see here. It looks fine in Illustrator CS6, it looks fine in Glyphs…but when I go to export, it fills in a portion of the path, as seen here. All the paths are outlined strokes in Illustrator, so they are filled objects.

I had the same problem with the character G. I’ve tried redrawing the characters, which didn’t help. I’ve tried copying the characters from Illustrator into a new Glyphs file, then onto the actual Glyphs file (which worked for the G). I’ve tried Shift-Cmd-R (Correct Path Direction), which moved the problem to the opposite corner (shown here). The path looks like this

I’m not sure if this is something I’m doing wrong, or if it’s some bug in IllustratorCS6 or Glyphs. Anyone have any ideas?

Thank you all in advance!

I’m currently running on OSX 10.8.5, if that helps.


It looks like you have open paths. Look out for small blue stroked on some nodes. Open paths are not allowed in .otf fonts.

Try also to tidy up paths (cmd-shift-opt-T) and export again, with hinting disabled. If that does not help, please send the glyphs file to support at this domain.

Woah, you fellas are quick ;). I’ll look into that & get back to you. Thanks a lot!

Yep, that did the trick! Thanks!