Strange interpolation artifacts

Font troubles are following me for the last few days…

Now here’s this:
Although it looks as it should in Glyphs, in all other apps there’s some weird distortions in random glyphs of random weights. I’d understand if there were problems with ALL the instances, but it’s impossible even on paper for such bugs to be in only one or two weights…

What’s even more strange is that this happened when I started to link Bold styles. I wasn’t touching the vectors. So it’s very annoying since you can’t fix the problem because there’s no obvious cause - it’s all random.

On off-topic note, I noticed that InDesign specifically can’t handle /Germandbls substitution as outlined in the Blog. It can give either all caps or #case forms. Not both. It’s either uppercase with lowercase punctuation or case-sensitive punctuation without /Germandbls.

Llooks like a remove overlap problem. When I had similar problems at one point, I simply re-exported it a second time, and suddenly it worked. Does it always appear in your case or only sometimes?

The locl trick was tested in InDesign. When switching to all caps, InD transforms /germandbls to /S/S. But that’s not the point, because you can still use the u1E9E character, which will not be replaced. The case solution is for TextEdit and other engines, not InDesign. I’ll reformulate the passage to make that clearer.

It was already happening for few exports and is still going on. Except /one is fine now. Weird.

So how to get both capital ß and case-sensitive forms in InD?

Do you have any custom parameters applied in the instance(s)?

You need to insert the actual character, i.e. ‘type’ u1E9E. You can do that with the Mac character palette (not to be confused with the InD glyphs palette!) or with copying it out of UnicodeChecker.

Only round corners filter. I did few more exports and nothing changed except /one is broken again.

If the export problem occures again, could you send me the .glyphs file?

It is the Round Corner filter that causes this. When I had this problem, simply exporting again usually fixed it. FWIW, the file you sent us exported nicely on my machine, even /one. If the problem persists, you may want to delete the most recent folders in your Temp folder, or in the worst case, rearrange the nodes in /one to make it a little easier for the filter.

Deleting temp folders fixed letters with descenders.
/one got fixed by turning yellow interpolation section into green. (this one was getting broken every other export).
Letters with diacritics got fixed by adding a single node to them.
And the rest - by moving nodes around a bit.

No. Now other letters/weights are messed up.
What’s weird is that /one.numr of /onehalf is broken, but /onequarter is fine…
While /one is broken in just every other version.

The filter is applied after decomposition. You can try rounding coordinates and updating metrics.

Updated the metrics and everything’s fine for now. Fingers crossed until next export.