Subfamily is out of order is Adobe Menus

Hi all,

I am pulling my hair out trying to understand why this keeps happening. I’ve changed the weights, widths, etc to be chronological in numbers, but this particular font is giving me a lot of strange issues with ordering (I am not experienced well in glyphs at all)

Screen Shot 2021-11-27 at 12.52.47 PM

(Also I do not know why the Condensed Light Italic has a HUGE sample preview text)

When I investigated, I found a ton of elements like custom parameters, continue to revert and show up no matter how much I change these settings or delete them and export.

Screen Shot 2021-11-27 at 12.53.11 PM

![Screen Shot 2021-11-27 at 12.53.44 PM|690x25

(This is for a condensed medium italic weight, and the master name keeps reverting to “Extra Bold”)

(I suspect its this parameter that is messing with the orders, but I cannot get rid of it)

(more custom parameters, that I do not understand and will not go away. I don’t know enough to know if they are interfering with the order)


The order is determined by the weight and width classes in the instance settings. It is explained here: Naming | Glyphs

Yes, I appreciate the response but I meticulously set each width and weight to be ordered, only for it to revert to these weird custom parameters (me setting the weight to something like 800, only for it to be at 200 when I reopen the exported font).

There are also these things like “style map name” that won’t go away.

The order is being jumbled, and it’s not so clear to me why.

Can you send me that .glyphs file?


Reopening the exported font in Glyphs is not a good way to test your fonts. Better use OTMaster or ttx or FontGoggles etc.

What is the best software for this issue in that case? I’m on a Mac

The goal is to redistribute the weights to be in order that I would like in the adobe menu.

If you want to edit data such as the weight class of an exported file, use OTMaster (visual editor) or ttx (edit as XML code). If you have the original Glyphs file, set the weight class in FileFont Info…Exports.

1 Like

You need to set the weight/width class according to your styles. For weight: use 300 for Light, 500 for Medium and 700 for Bold). And width: use 3 for all styles. And check the “Is Italic” setting for all instances. This is all explained in the naming tutorial.

Were you able to get them all in order that way? (The files I sent?)

I set them all to be in linear weights from 800-806 I believe. The reason I put them at this number is because I wanted all my styles under one font menu (So Futura would fold out, and you would see all the styles from light, medium, book, bold, black etc, and then you would see condensed, neatly organized from condensed light to condensed bold in order at the bottom of the big list).

Is the issue something else? I’ve not really gotten a clear understanding as to why those particular names are out of place, and the settings within the file revert / won’t let me change them. Things like “Style Map” that seem to be interfering with the ordering

Yes. They where all ordered fine. There is one file with a different Width class. So you need to check them, too.