Suggestion: Paste-replace with Cmd+Alt+V instead?

This new feature that allows you to connect what’s in your pasteboard to the selected path is a feature I rarely need, especially when I am cutting and pasting something. In those cases the shape don’t match and don’t make sense to replace onto the line.

When I delete something, the last point remaining is still selected and when I paste now, the content of the pasteboard gets pasted onto the end and is not what I need.

I suggest making the paste-replace shortcut Cmd+Alt+V (like paste special!), so that Cmd+V remains the normal paste.

1 Like

I agree, this is a feature I do not want; it doesn’t work the way I want even when I want to use it, and there is a bug in selection after cutting a segment. When I cut open a path by selecting on-curve nodes (not just handles if on a curved segment), a wrong node is selected; probably the third node from the start node?

1 Like

Anyone else has an opinion about this?

I don’t hate paste-replace as much as I used to, and it has been helpful for a particular set of alternates in Burmese, but I’d happily see it off by default and use alt to enable it.

Does it ever work for you? In my case, when I wanted to try, the outline is attached at funny angle and it doesn’t seem to understand my intention.

1 Like

an you send me a screencast of what you are trying to do?

That particular glyph needed different endings on a straight segment, and it worked fine. Other times it’s often attaching at a funny angle and just creating extra work (undoing, deselecting nodes, repasting).

(EDIT As I mentioned back in October, I was looking for a way to disable paste-replace: Pasting-replacing
I think having it enabled on alt is better than having it on by default.)

1 Like

Certainly. In the current implementation, 1. making sure to deselect all and 2. having to remember which node selection does which behaviour are not what I want to do. Even if it works in the way that Glyphs intended, I would still prefer to have it as an option.


i have exactly this issue

I agree with oneweioranother, Cmd+V should have a standard behavior and the smart trick should have a dedicated shortcut. Cmd+Alt+V sounds like a good idea to me. Anyway, you may add extra functionality to Cmd+Alt+V in the future, Georg, for instance Paste to Background, so I can imagine a popup menu after clicking Paste Special.


I changed it a bit that it will only paste in place when there are at least two nodes selected. That makes it less likely to happen accidentally.

1 Like

Has this been implemented in Version 2.3b (860) ? I’m still frequently accidentally paste-replacing.

It should only replace if at least two nodes are selected, now.

It’s still happening same as before in Version 2.3b (860).

I can’t reproduce it:

Just upgraded to 861, not happening anymore.