Sups ligature did not work

Hi, I’ve tried to make a ligature for .sups and it doesn’t work
I have H.sups, L.sups, H.sups_L.sups glyph

Glyphs did not generate it for me, so I included:
sub H.sups L.sups by H.sups_L.sups; under liga feature

Try using this glyph name for the ligature glyph: H_L.sups

Nice try, but didnt work also :frowning:

When you say it doesn’t work, do you mean that the H_L.sups ligature is not automatically included in the liga feature when you press the Update button at the bottom of the File > Font Info… > Features tab? If that’s the case, then rename the ligature glyph to: H_L.sups.liga, then press that Update button. Then, it should include the H_L.sups.liga glyph in the liga feature.

I suspect it is a problem with the feature order. Is the subs or liga feature first in the list?

The name H_L.sups is better then H.sups_L.sups.

1 Like

It works now. The problem was what @GeorgSeifert said about the order… Sups feature was below liga
This is a feature or a bug? hehe

You have to decide the feature order (actually it is the lookup order). It depends on the code.