Syntax error at "}" [features 245

Hi, i’m working on developing an Arabic typeface, everything was fine until i got this message:

“syntax error at “}” [features 245
No Files was created”

The font is still in progress, a lot of empty glyphs, but all the main Arabic characters are there.

The problem might be related to layers, that i created a layer for the glyph “ain-ar” to have alternative design for the character, then i clicked on the new layer to use it as master. this is the only thing am suspecting causing the problem!

This is an error in the feature code. Does the dialog give you the option to take you to the spot that causes the problem?

Usually this has one of the following reasons:

  • non-ASCII characters in your code (including comments or glyphnames)
  • one of the feature names does not adhere to the naming
    rules (exactly 4 lowercase ASCII characters and figures,
    no whitespace or punctuation)
  • a mistyped feature command like ‘sub’, ‘pos’ or ‘by’

If you did not write your own code, maybe clicking the circled arrow in File > Font Info > Features fixes it.

I looked in to it, and i couldn’t find any of the above reasons, bearing in mind that i didn’t wrote the code, its the auto generated code.

I tried to fix it by the rounded arrow icon, no luck.

also the software didn’t take me to the code error spot

Could it be a bug?

Can you send the .glyphs file to support at this domainname? I’ll take a look.

file sent.


I cannot reproduce the error, the font exports without a hitch here. Which version of Glyphs are you using?

am working with the Glyphs 1.3.17

Okay, I could reproduce it in 1.3.17. :slight_smile:

This is indeed a bug, which is already fixed in the recent Beta versions. You can do two things: either update to a Beta version with Preferences > Updates > Show Cutting Edge Versions.

Or, if you rather stay on the safe side, you can add a dummy Latin kerning pair, because the kern feature comes out wrong when there are no Latin pairs. Generate A-Z and kern AV to a value of -10, then export again. Worked for me in 1.3.17.

Hope this helps.

This is weird because i was working on the font for a while and everything was fine until i added the layer thing.

Any way, thanks for the help.

The second solution works fine for now.

Great app by the way, and great support :-).