Syntax error at ".notdef"


recently, I added a lot of new glyphs to my font. Since this operation, it is impossible to export the font due to an MakeOTF error. I ran the makeotf command the terminal, and here is the complete error message:

Last login: Mon Sep 8 10:47:26 on console
Christinas-MacBook-Pro:~ christina$ /Users/christina/Library/Application\ Support/Glyphs/Temp/Espal-B9-S-exporttest-Regular/generateFont.command ; exit;
syntax error at “.notdef” missing NUM [features 20]
makeotfGlyphs [FATAL] aborting because of errors

[Opération terminée]

I don’t have written any features or scripts yet.

Where do I need to search for the error?

Thank you very much!!

“missing NUM” means that there is a numerical value missing in a positioning lookup.

Try Window > Kerning > gear menu > Compress and export again.

Try File > Font Info > Features > Refresh (button in the lower left corner).

If that does not help, please send the font to support (at) this website address without the www.

For future reference, the problem was a faulty unicodeRanges custom parameter. Simply deleting the parameter solved the problem.