Tab Oldstyle, export not working

Glyphs 2.2.1

Suddenly my Tab Oldstyle Figures does not appear when selected in InDesign CC, even though they are to be found in the Glyphs palette (InDesign). It works fine in an older version of the specific font.

I can only find one difference between the old and new version: In the Glyphs Palette (InDesign) the old tab oldstyle glyphs are named: (tnum) + (onum)

But in the new version: Access Alternates, 2 (aalt) + (tnum)

Anyone know why?

I would need to take a look at your file.

Thank you, I’ve just send you the file. Best, Rasmus

I had a look at your file.

  1. I suppose your default figures are supposed to be tabular lining figures. Two figures (zero and three) had inconsistent widths. I fixed that.
  2. There was an unnecessary empty set of .tf glyphs, which I disabled.
  3. There was an unnecessary handwritten lnum feature. I deleted it.

After recompiling in File > Font Info > Features, the features work again as expected.

Thank you! Now it’s all good :smile:

Thank you very much.

hi, I have the same problem (in Glyphs mini 2.1.3).
i created the non-existing Oldstyle Figures, even though they are to be found in the Glyphs palette (InDesign), they do not not appear when selected in InDesign CC.

I did not understand the solution that mekkablue proposed.

Anyone know?

Mini does not support the OSF feature:

Automatic OpenType feature generation for localized forms, fractions, ordinals, discretionary and standard ligatures

For full OT support, you need the full version of Glyphs.

thanks mekkablue, for your answer. I downloaded the full version and tried again in trial modus : same problem…

Have you updated the features in Font Info > Features > Update?

hello Georg, thank you so much for responding in such sort notice. I was away and could only check it out today. It works. Thank you for your help, and also thank you for making me understand the difference between mini and full version. I will update. Have a nice day

1 Like