Test install not working – Glyphs 3

Hi wonderful hive mind,

I can’t get my font to update after I export it more than once. I’m using Glyphs 3, Big Sur 11.6, and the latest Adobe update (mostly AI and IND).

Neither “Test install” nor saving to the Fonts folder I created are working. After I export my font for the first time, I can find it in my Adobe programs and it works. BUT, when I make updates and export again, the export says it’s successful but the updates don’t appear in Adobe unless I quit and reopen. As I say, it doesn’t update regardless of which export method I use.

The testing function DID work flawlessly for me until I upgraded to Glyphs 3 last week. In Glyphs 2, when there wasn’t a test install function, I was using the export to Fonts folder method and it was seamless.

I’ve tried the following tips that I’ve seen in this forum:
• deleted and recreated the Fonts folder in the proper location
• restarted my computer holding Shift, then restarted again
• removed the font from my computer then tried again
• used Terminal to paste the code I found here: Eliminating Font Cache Problems | Glyphs then restarted

I am having trouble using the pasted script trick from that same article because I don’t seem to have a Scripts folder in my library! If this is the issue, can I just create that folder myself? (I would be very surprised if this is the issue, though, since, as I say, the testing function worked when I was using Glyphs 2 up until a week ago!)

Thank you in advance!


When you used the “Test Install” function, you might need to restart Glyphs or even your mac to get rid of the installed fonts.

When you test in Adobe apps, the export folder is still recommended. And that should work the same as in Glyphs 2.

1 Like

Thank you, Georg. I have gotten it to work by deleting the Adobe fonts folder I made, recreating it, and then renaming my font. I’m also no longer trying to use the “Test install” function. Hopefully this continues to work!