Text 'T' tool and 't' shortcut not producing text preview, everything hidden on white screen

What Am I doing wrong here? In Glyphs 2.6.5 when I type ‘t’, I get the usual black preview of the glyph I am working on - as expected. I type another character next to it and then double click to edit that one.

I have just updated to Glyphs 3, now this doesn’t work at all. The ‘t’ shortcut makes the entire workspace go white hiding everything in the window and I cannot type another glyph into the edit window at all. Double clicking brings the vector glyph shape back - preview is not available in the main editing window as far as I can tell.
I’ve been through all the menus and can find nothing that helps

Same issue if I click the Text (T) tool…just not working as expected


Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

Can you try to start the app without plugins. Hold down the Option and Shift key when you start the app.

Yes - when I start up the app without plugins it works fine.
Should I remove them all and add them in one by one or is it something more than this, perhaps.

Thanks as always for the fast responses.

I cannot reproduce the issue, neither in version 2, nor in version 3. Can you try deleting the App Support folder, then reinstalling plug-ins through the Plugin Manager one by one, and each time see if the issue occurs again?

That way, we might find out if it is a plug-in that causes it.

There is an extra tool in the text tool. You should try to remove it.

You were right - I have removed the Extrude tool via the Plugins Manager and this removed the extra menu item under the text tool and the problem is resolved.

Thanks again

you can install the Extrude tool again. I have moved it next to the text tool

I tried everything and non of them seemed to work. :frowning: