Text Tool Window

1.4.4 [597] Mavericks

A couple of things about this:

  1. When using the Text Tool and typing characters in the Preview that are shortcuts to the tool set, instead of the desired character I get the related Tool, then have to grab the mouse and reselect Text Tool again. Can we have a Preference setting for that window to disable shortcuts to the Tool set?

  2. When setting Kerning in the Info box, if I click on the left side lock to unlock that character to override the group setting, the lock does not stay open after a new value is entered and the new value is getting applied to the group.

1: no need for the mouse: if that happens, try T for Text tool.

What do you mean by typing in the preview? The edit view is configured to only type that’s why you need to hit esc to go back to the select tool.

To me, Edit View is when I have an outline showing; Preview, to me, is when I select the Text tool and the glyph changes to a solid. That’s what I’m referring to. Maybe I need a list of what the various views are called because I think we’re referring to different things.

When I’m typing various characters to set or check kerning, frequently but not always when I type a character that is a shortcut to the tool set and am expecting that character to show up on-screen, instead it changes to that tool. That forces me to have to reselect the Text tool – or as Rainer pointed out, type a /T. Either way, it is an annoyance.

When I have just opened Glyphs, this rarely happens. After I’ve been using Glyphs for perhaps an hour or so doing various things, it begins to happen. When it begins to occur, I’ve found that if I use the arrow key to move the cursor to the right end of the pair/string it will help prevent it, but not always.

As for pressing the /T, one oddity about that is that sometimes, even with the Text tool reselected after the above has begun to manifest, pressing the /t, even repeatedly, does nothing. I will do some tests today, try to make this /t problem happen again and let you know what I did to get around it.

Possibly just restarting Glyphs would reset the behavior to normal until the next occurrence. I haven’t tried that yet.

To me, this happens only when the cursor is at the last position in an Edit tab.

I haven’t experienced the pressing-T-does-nothing issue yet.

This is the nomenclature we use in the handbook: ‘Preview’ is the narrow preview bar at the bottom which appears when you click on the button with the eye symbol on it. The whole thing is the Edit view (as opposed to Font view), and you can be in the Text tool or in any of the other tools. The issue at hand is that you are involuntarily switched from Text tool to another tool.

re: Preview vs. edit vs…
Since I wrote that I referred back to the manual and finally figured out just how many different views there are and how to refer to them – so now I’m good there.

Exactly. And just now I may have hit on the answer to the "/t does nothing" problem, thanks to what you wrote about the last position. I will test it later and give you an update.

I have seen the issue with keys changing the tool rather than typing the character sporadically, but I think I have just stumbled on a reproducible occurrence of it.
In text mode, if I hit in rapid succession spacebar and a tool key (for example a or v) Glyphs will switch tools. If I instead put a pause between the space and letter it results in the letter being typed as desired.
Hope this info helps debug the issue!

Bumping this, because the accidental mode switch when typing test strings is an ongoing annoyance. Does the spacebar observation I made above help fix this?

Thanks for the reminder. I fixed it.

1 Like