The font contains glyphs with the same name: Aring.ss03.varAlt01, aring.varAlt01, aring.ss06.varAlt01 …

This worked (in previous versions), but I opened the Glyphs file, made some changes, then tried to export I got this error

This must relate to the bracket switching layers, of which there some in both the base glyphs, and in the ‘ring’ diacritic, and I’m guessing that this is what makes Glyphs wobble.

Anyhoot, this used to work, just not anymore. I’m on the cutting edge.

“Befor” you needed to duplicated all bracket layer form the base glyphs in the composite. Now it is the opposite, it causes trouble if you have different bracket layers in the base and the composite.

Wait what? I never knew about that one-directional limitation. But now it has changed to the opposite. Okay.

I just checked and both base- and diacritic have one alternate layer (per master) for [wg<650], and no bracket layers in the composite. They should be compatible no?

I need to have a look. Merging bracket layer is quite tricky.

Does that mean the wrong anchor placement/wrong spacing is fixed when I don’t reproduce the bracket layers in composites? :eyes:

I ran into this again while trying to make these bracket layers work (they don’t, and now Glyphs can’t generate the fonts).

As recommended I made the exact same bracket layers in the composite glyphs as there are in the components. That didn’t work, as in the generated fonts there were no switching going on.

Removing the bracket layers from the composite glyphs now again gives me The font contains glyphs with the same name: longs_k.liga.varAlt01, k.varAlt01, f_k.liga.varAlt01, longs_k.liga.varAlt01, _f_k.ligature.varAlt01, _longs_k.ligature.varAlt01 …

If I have to make the identical switching layers in the composite glyphs, do I then also have to make them where these glyphs are used as components, ie. in all the diacritical composites such as hcaron? Can’t this be automated?

Hey Georg. Please have a look at this. I have been unable to generate VF fonts since this started.
The Aring.xxXX.varAlt01 &c errors have magically healed themselves, but now I have the following error The font contains glyphs with the same name: longs_k.liga.varAlt01, k.varAlt01, f_k.liga.varAlt01, longs_k.liga.varAlt01, _f_k.ligature.varAlt01, _longs_k.ligature.varAlt01, kgreenlandic.varAlt01, h.varAlt01, n.varAlt01, f_h.liga.varAlt01, longs_h.liga.varAlt01, _f_h.ligature.varAlt01, _longs_h.ligature.varAlt01

I can clue you in on what I think is – partially – the issue, and that is that both n, h, and k are composites of reusable components, components which themselves have bracket layers.

Would you please have a look at this issue. I have now tried all the possible permutations of turning on/off the duplicated bracket layers for all involved components. This time the issue is that my ‘base glyphs’ are composites made from components. Glyphs can’t figure this out I think.

Any progress?

I ran into the same issue: /idotless has a bracket layer, /dotaccentcomb has a bracket layer with the same axis values. The error during variable font export:
The font contains glyphs with the same name: i.varAlt01, idotaccent.varAlt01, iogonek.varAlt01, i.TRK.varAlt01
I tried with Glyphs 3.1 (3151) and Glyphs 3.2 (3207).
Removing the bracket layer from either /idotless, or /dotaccentcomb works, but it’s not the desired output.

We got it working (in the cutting edge build), and you should only have the bracket layers in the glyphs where they are needed – meaning don’t duplicate the bracket layers in the composite glyph, Glyphs should then handle it. Also: Problems can occur if you have differing bracket layer configurations in component glyphs that are then used together in a composite glyph.

Lol. I realised I made a mistake on my part and added the Alternate Layer to the wrong glyph. It’s working now with the latest beta build. Thanks for letting me know!

1 Like

Hi Georg. I have the same problem and I can’t solve it by applying what you propose above.

Could you check it please? I am probably missing something
Here you have the link to glyphs file: Mazuma_exporting trouble.glyphs


The font you uploaded exports fine in app version 3208 (download link).

It works perfect. Thank you so much!