The font contains glyphs with the same name: newGlyph

When I try to export my font, it wont export and keeps reading: "The font contains glyphs with the same name: newGlyph"
And I just dont know what to do, because I am new at this.

Have a look at the end of the font view. There you will find several ‘newGlyphs’s. You probably can delete them all (or rename them to some thing useful.

Glyph names must be unique throughout the font. And there seem to be multiple glyphs that share a name.

Sorry for the silly question, but I am looking for the same help. Where is the “end of the font view” in the UI?

Font View is the main window where you see all the characters in the font. End of Font View means to scroll to the bottom of all the characters in that main window.

Does this apply when we’re first crearting the font, or also when we open up a created *.ttf file? I need to do the latter, and then save some changes. Now while saving I keep seeing this duplicate message.

Check for glyphs with the same name. Glyph names must be unique in the font. Read this please:
https://glyphsapp.com/tutorials/importing-existing-fonts

Thank you. I’ve read the help. For a collection of fonts in the same set, as identified in the font info -> “master”, is there a way to:

  1. More automatically find duplicates (e.g., by searching the names shown in the error message?)
  2. And change them (maybe remove from “Export”) all together across fonts within the same set?

THe Help is not clear about how to do this. Thanks.

Well, the error message tells you the name, in your case newGlyph. Simply type it in the search field of Font view.

A glyph has layers for all masters. I.e. if you delete a glyph, it is also gone in all masters.

Hello, world!

I am getting a problem with a similar error report at Glyphs 3, although it gets exported fine (with no error report) from Glyphs 2.

At the Glyphs file, I have only a glyph with name cent and cent.tf, nothing with such suffixes. Do you know where this comes from?

That can happen if you have bracket layers in a composite glyph. In this case probably in the ‘cent’ and ‘cent.tf’. You can probably remove the bracket layers in the later. Those where needed in Glyphs 2, but are not any more in Glyphs 3

3 Likes

Great! It gets exported.
Thank you for solving the issue, Georg!

Hi again,

I have a similar problem with Glyphs 3 but I don’t really understand what is wrong. I have bracket layers in N and s, but nothing in the accented ones as they are components. What can I do?

Can you update to the latest cutting edge version? (Activate it in Preferences > Updates)

I just updated but it still doesn’t work.

Can you send me the .glyphs file?

Sorry that it took so long.
The problem is the bracket layers in the ‘s’ and the ‘commaaccentcomb’. The decomposition of those bracket layers into the composites doesn’t support having two components with bracket layers, yet.

I’m pretty sure, that you would be better off with a brace layer in the ‘s’, probably in the ‘commaaccentcomb’, too.

No worries Georg!

Indeed, impossible to export a VF with glyphs having two components with bracket layers. So I changed one with brace layers and now it works, thanks!