The font files of 60,000 characters

On Macmini, Glyphs is sometimes slow or even collapsed when processing the font files of 60,000 characters. Will it be significantly improved if you use Mac Studio? Glyphs mainly uses the performance of the CPU, or the performance of the GPU?

Tip: The application has no response.

Glyphs uses mainly the CPU. A Mac Mini should be enough to handle large projects, but it also depends on the type of work you do in Glyphs. Which operations are you performing that make it so that there is no response? Are you running certain scripts or filters?

This occurs when the prompt file is locked, at which point the save as option will not be matched. Select OK, and then save as a project file on the normal.

What machine do you currently have?

Mac mini M1

Then a Mac Studio shouldn’t be a big improvement.

The curves in that font aren’t curves, they’re lots of short straight segments. Could the root of the problem be the huge number of nodes in the font?

Mac Mini M1 ,Memory 16G.
Will increase memory improve performance?

What exactly are you doing when the slowdown occurs?

  • Are you exporting an OTF? Make sure you disable subroutinization (there is a custom parameter for that, see the Complex Outlines tutorial). Consider also disabling autohinting. Both options are processor-intensive.
  • Make sure the text in an Edit tab only has the glyphs you need for editing, it is not made for long texts.
  • In Edit view, reporter plug-ins can take up a lot of performance, especially those written in Python. Make sure you only have on what is necessary in the View menu.
  • Turn off the Preview at the bottom of an Edit tab if you have text longer than a few characters. If you want to preview larger texts, consider Window > Text Preview.

thank you

Just simply having them installed? Even when they are turned off?

A lot installed (but inactive) plugins might still slow down a tiny bit. Starting without plugins can make sure that is not the case (hold Option+Shift when you start the app).