The Gray Info Box in Glyph view is missing (Version 1.4.5 (614))

I have a file (italic) where the gray Info Box in the Glyph view is not showing. When I try to hide and then show it again Glyphs crashes. (When Glyphs restarts and I’m asked to file bug report Glyphs freezes.) Any ideas?


  • I open “O”, no glyph info showing.
  • I go backwards (using keys), from glyph “parenright” on info box shows again
  • I go forwards info box stays visible

Console says:
24.04.2015 14:15:45.147 Glyphs[569]: (
0 CoreFoundation 0x00007fff9862c66c __exceptionPreprocess + 172
1 libobjc.A.dylib 0x00007fff90c1176e objc_exception_throw + 43
2 CoreFoundation 0x00007fff984f6df4 -[__NSArrayM objectAtIndex:] + 260
3 GlyphsCore 0x0000000100265d7f -[InspectorViewGlyphController _reloadContent] + 715
4 GlyphsCore 0x00000001001fafb4 -[GlyphsPathPlugin inspectorViewController] + 6120
5 Glyphs 0x000000010002d9ac Glyphs + 186796
24.04.2015 14:15:47.352 Glyphs[569]: *** -[__NSArrayM objectAtIndex:]: index 999999 beyond bounds [0 … 11]

Can you select the O in font view and click the remove color label button in the info view in the lower left?

Excellent, this solved it.
(I also had crashes whenever I tried to use Add Component, which also shows the colors of glyphs.)
Thanks for your quick reply,