My macOS is 12.2.1 and my Xcode is 13.2.1. I make the plug-in by OC on my MacBook. My Glyphs3 is installed and used normally, but when it is installed on the macOS of 10.15（the same is G3）, it crashes directly. when reopen G3
it warning ‘Please confirm whether the latest version of the required module is installed’ What are the reasons for this problem? Does it have anything to do with macOS deployed target? Because I don’t have a 10.15 system, I can’t debug it.
Have you made a release build?
Have you set the
MACOSX_DEPLOYMENT_TARGET to something lower than 10.15.
Do you use any macOS API that is not available in 10.15?
Can you check the crash reports? Do they show anything interesting?
Can you send me the plugin?
These two adjustments succeeded . I used Python all the time.use OC and Xcode at the beginning, and everything was still very ignorant.
I also want to ask whether the Xcode templates of G2 on GitHub can still be used. Which branch is the final version?
Use the templates from the Glyphs3 branch.
The template I used Glyphs3 branch, the loaded FRAMEWORK_SEARCH_PATHS and GlyphsCore are G3, and Debug’s DSTROOT is also G3. If I want to make a G2 plug-in, do I need to change them to G2?
You need to link to the Glyphs 2 framework. And make sure that the headers are taken from the Glyphs 2 Core framework.