The software does not open

Hi, I’m having a problem when I try to open Glyphs. No window opens and there is no indication that it is open. Have you encountered this problem before? Thanks in advance

What version of Glyphs are you using? With Glyphs 2, it might appear it’s not open, but in the top left, you will see “Glyphs” menu items. Open a file from there.

Thank you for your reply. I’m using the Glyphs 2 version. However, there is no indication in the toolbar that the software is active.

What version of macOS are you on? Does the app icon appear when you hit Cmd+Tab? Is it listed in the Activity Monitor?

I’m using version 13.4. The Glyphs application icon appears when I press the Cmd + Tab buttons. thanks for your help !

The same thing happens when you open a .glyphs file?

Exactly, it is impossible to open a .glyphs file.

Do you think this is due to the software? If so, should I upgrade to Glyphs 3 to fix the problem?

Glyphs 2 does not show a window when launched. Use FileNew to create a new file or FileOpen… to open an existing file. Or double-click a file in Finder to open it.

Glyphs 3 shows a start window when launched, which makes it a bit more obvious that the app is running and allows you to create new file or open existing files directly from that window.

Thank you for your message. The thing is, it’s impossible to perform this action, or even to open a file.

What happens when you open Glyphs? Does the Glyphs app icon appear in the Dock? Is there a small dot below the Glyphs app icon?

No sign that the application is open, either by the small dot below the icon, or in the side toolbar

Have you read this:

If that does not work, then there is something very wrong with your installation. Try deleting and redownloading Glyphs.

OK, thanks. No dialogue window actually opens. I have tried several times to delete and install the software but nothing changes. Do you know where to find the Glyphs 2 download link? It seems to me that it is no longer available on the glyphs site. Also, do you think it would be a good idea to switch to glyphs 3 if the problem doesn’t get solved? Thank you very much for your help.

It happened to me few times as well and took a bit to find out how to fix it. I reinstalled everything, but what helped was to remove the file that I had open before glyphs fell. I also didn’t have any indication of Glyphs being open.

I guess Glyphs was trying to open corrupted file or something, and removing it (at least temporarily) stopped glyphs from trying

Download link is on Buy | Glyphs, below the buying options.

Follow the steps in the Crashes tutorial. This sound like a crash during startup, I suspect a plug-in or corrupted autosave file. The tutorial explains how to take care of it.

I’m having a similar issue. I was prompted by Glyphs to download the latest Python update, which rendered Glyphs unusable. I can now only open the app with Option + Shift, it gets stuck otherwise. I deleted Python from my system, since it seemed to introduce these issues. I turned off the Plugins folder, also deleted most of my plugins (still need those Remix Tools, didn’t delete those); this procedure enables the app to open normally, however I need some of the Plugins restored.

Everything else beyond that I found on the forum is beyond my technical comfort. So here I am on the Forum, for the first time ever :slight_smile:

To clarify my questions… If I disabled my Plugins to open Glyphs, how do I restore the Plugins? And what’s up with the Python update?

If you delete Python, you will only be able to run non-Python plugins like RMX tools.

Which app version?

Did you have the python from Glyphs or installed in the system?