Tosche's instance sliders script

First @Tosche – AWESOME! thank you very much for that.
second, Glyphs is always crashing when using the script, but as reported on “El capitan crashes”,
I don’t know if is the script or El Capitan problem.

For those who haven’t seen it

It works fine for me.
OS X 10.11.3

It works fine for me.
OS X 10.11.2

I got some reports regarding tabs. Because the initial script was assuming that you have some tab already open, it wouldn’t run when you had none. I changed it so it forcefully creates a new tab when necessary. Also note that this script probably works only in G2.3 and later versions.

By the way, I am planning to add support for InterpolationWeightY custom parameter. Stay tuned!


Added support for InterpolationWeightY custom parameter. Enjoy!


Holy crap this is incredible!!!
[Edit: Does InterpolationWeightY use the stem values in each master? @GeorgSeifert ]

I don’t think so. If I understand correctly, it only looks at Y coordinates of each master and interpolates them separately.

Quite recently the script stopped working, saying that there’s no module named robofab.interface.all.dialogs. I tried changing UI language, reinstalling the module (& restarting the machine), but all scripts that use robofab don’t work. Does anybody have the same experience?

Instance slider works for me.
Version 2.3b (865) / Capitan 10.11.2 (15C50)

Works for me. Version 2.3b (865), OS X 10.11.3 (15D21)

@Tosche – Check your Scripts folder and make sure and are both at the top level of that folder. I had this issue recently with a failed plugin and being in a subfolder turned out to be the cause of the failure.

Do you mean directly beneath the Scripts folder? Those scripts were present. I tried removing them and restarting the app with no avail.

Both scripts need to be directly inside the Scripts folder (no sub folders). Did you get the latest version?

I’m using 865 and have those scripts back under Scripts. I can import vanilla but not robofab.

I think Georg was asking if you have the latest version of the two scripts. At least one of them had an update not too long ago,

How can I update them?

Download the zip file from here:

Unzip the file, then copy the two scripts from the unzipped file to your Scripts folder and let them overwrite the old versions.

I’ve updated and but now @yanone 's
speedpunk tool does not work any more. As I select it the working area becomes blank (glyphs disappear).
I’ve also updated to the latest version of G2 so maybe it comes from there.

After a quick test it’s causing SpeedPunk to misbehave.

I fixed a few things in the that should fix Speedpunk.