Transformation Filter Not Working in 2.3

I just noticed that since I’ve upgraded to 2.3, my Transformations “Background” feature no longer works. If I paste paths into the background of my glyph and then run the Transformations filter, I can move the “Background” slider around and see my paths interpolating, but when I hit OK, it doesn’t apply my adjustments. It just goes back to how it looked before I ran the filter.
Has anyone else notice this? I tried restarting the program, but I get the same result.

Works properly on my end. Also 2.3

I’ve now tried it on two different machines, both with version 2.3 (895) installed. I get the same bad result. I’ve also tried it with different files, so it doesn’t seem to be a problem with one particular file.
Again, I can watch it interpolate between the background and foreground as I adjust the slider, but when I choose a setting and hit “OK”, my adjustments aren’t applied.

This is a bug. We are aware of it and will try to fix it for the upcoming beta.

Thanks for looking into it!
The “Background” slider is one of my favorite and most used features of Glyphs.
I’ve gotten so used to depending on it, I’m finding it hard to work without it as I fine tune my paths.
Anyway, I look forward to its return.

As a workaround, you can use Masters > Variation Interpolator from my Scripts repository. It creates x number of additional glyphs with the background interpolation.