Transformations bug affecting another layer

When using the Paths>Transformations command it sometimes crashes another layer. The width is set to 0. Also I noticed that an italic angle is applied (when it is set in the Transformations window?). I don’t know if the moving X and Y values might also apply in the bug. It does not happen to the selected layer, so setting some values and pressing OK does not show me if something went wrong. The buggy layer is affected immediately when opening the Transformations window. When I notice it in the preview and I cancel the Transformation it is still destroyed. The Undo command does not work to fix it.

I can’t tell when it happens and when not. If I remember it right, it also happened with the Transform Metrics command. It happens for a while now. I don’t remember in which version I noticed it first. I use 3.1.1 (3148).

Can you be a bit more specific of what you mean by “another” layer? Is it a layer you recently worked on?
And any reason you are not using the laters version?

I mean another master layer. So if I am working on the Bold layer and select Transformations it might affect the Regular layer. I am not sure if it ever affected a special layer or a layer copy.

You might be right that is a layer I recently worked on. I remember in most cases it was Light or Regular while editing all of them in this order. But from my memory it is not necessarily an edit with the Transformations command.

I deactivated the cutting edge versions updates at some point. I thought it was when I had a stable version. Just noticed 3.1.1 (3148) is not. I just updated it to 3149. I guess for now I’ll work with cutting edge versions again.

I have Mac OS 12.6.1 (21G217) by the way.

Do you have any plugins installed. e.g the sync metrics key plugin could mess things up like this.

Installed Plugins:
Red Arrow
Show Angled Handles
Show Distance And Angle Of Nodes
Speed Punk
Variable Font Preview X

Installed after first occurrences:
Kern On Glyphs 3

Does it mean the problem doesn’t occur when there are no plugins?

I just deinstalled the plugins properly from the plugin manager. I only deinstalled RMX und Kern On by deleting them from the plugin folder. The issue still exists.

I tried to reproduce the issue, but I can’t exactly tell what needs to be done in which order to let the master crash. But I now can confirm that it happens with the transformations command, the transform metrics command and the interpolate with background command. And yes, it is always the master I did the last edit on. While testing I used a lot the swap with background command (or however it is called in English), but it is not necessary to reproduce the issue. I thought it needs an interpolation with background somewhere in the process, but it doesn’t. It seems like it only occurs when I change the command. That means I can switch between the masters and transform as much as I want. The moment I use Transform metrics it crashes the former master. But it does not happen every time. I first need to edit a few masters with Transformations.

There were still three aliases in the “Plugins OFF” folder:

Speed Punk does not exist (anymore), while Super Tool and Curve Equalizer were in the Repositories folder. I removed the left aliases and their respective originals from the Repositories. The issue still occurs.

Can you send me the file?

The bug still exists.

It also appears between two different glyphs. Maybe this will help to find the origin of the issue: I wanted to interpolate with background in glyph B. That set the width of A to zero while the side bearings values with metrics keys still had the former values, and there were not red. I set the width to an arbitrary 600 and update metrics, which does not take the values from the metrics keys, but sets the width to zero again, now showing red metrics keys. I tried it a second time and the values from the metrics keys were taken.

I tried a completely new installed
Glyphs App 3.1.2-3151 (I think it was)
on a completely blank system with a freshly installed
macOS Monterey 12.6.2
I created a new glyphs file with three masters, simply made a rectangle in each master layer of a glyph and played around with transforming. The bug appeared too. So, I guess it can’t be my file or my Glyphs installation.

Now I use MacOS Ventura 13.2 (22D49) on a different hardware with Glyphs App 3.2 (3178). The bug still appears, so I guess it is not the hardware either.

It is no discussion here in the forum, but I can’t believe I am the only user experiencing that. Depending on the design process phase it happens up to 50 times a day. Thank you a lot for your help.

Can you do a screencast what you are doing? That would help a lot.

Here are the screencasts I sent you a month ago.
Feel free to send specific instructions for more screencasts.

I understand your decision to assign this matter a lower priority, but I thought I’d inform you that I still experience this weird bug in version 3.2 (3208). Despite the bug itself, do you have any explanation why I seem to be the only one reporting this bug although I have the impression that a safe mode and different hardware reproduces the bug in the most basic workflow?

I did look into this but was not able to reproduce it.