Tricky Uppercase Diacritics in Glyphs Mini

I purchased Glyphs Mini to modify a handwriting font that I originally created using the iPad app iFontMaker to incorporate some special characters with diacritics. I’m sure that this is not a “best practice” for typography creation, but I was originally made the font for my own personal use on a quick project with the understanding workarounds might be necessary. Now I’ve been asked to share the font with others working on a bigger, related project; I’m more than happy to do this, but I want to fix up the font and make sure it functions properly without workarounds before I share it with them.

I have already relied on the excellent documentation in the Glyphs Mini manual, the posted tutorials, as well as answers to previous questions in this forum. All of these have helped me solve a lot of the initial problems with my font (especially with regard to the spacing and kerning). The special characters I need to be able to type are: x̂, ĝ, and d̲ as well as the uppercase versions of these. Again, with the help of the tutorials, I’ve been able to create the lower case characters with the circumflexes and low line accent without a problem. I have made glyphs for all of the variations on these accents (i.e., circumflex, circumflexcomb, asciicircum, and lowlinecomb) and have made component glyphs to represent the special characters. It’s all been working great, despite my ignorance, thanks to the tutorials and helpful tips here.

Here’s where I’m running into problems: lowercase of the special characters seems working fine, but uppercase is not working for the X̂ and Ĝ. I have tried to follow the instructions in the Uppercase Diacritics section of the diacritics tutorial and I’ve created a glyph and modified my basic circumflex. I’ve made the component glyphs, which look great in the program but when I export the font for testing it doesn’t look like the uppercase combining circumflex is being used and just the regular circumflex is kind of smushed on top/overlapping with the uppercase letters.

I will need the font to work with Microsoft and Adobe products, so those are the two programs I am using to test the font. I’ve followed the advice to save each new version/attempt with a variation on the core file name, and I’ve also followed the instructions here on clearing the cache to eliminate font cache problems (and I’ve restarted my computer). I’ve tried downloading the TextPreview app, but can’t get it to work on my system. I’ve tried scouring the forums for similar problems—maybe I’ve just missed the right posts, but I can’t find a solution.

I’m not sure what I’m doing wrong. It’s highly likely that I’m making a simple mistake, or that some glitch from the original font creation in iFontMaker is the cause (maybe my original iFontMaker letters are the wrong proportion?), but I think I’m officially past my ability to troubleshoot by myself. This is probably the last step I need to figure out before I can share my font. If I can fix these uppercase special characters, I know the font will not be perfect, but it will be sufficiently good for our purposes. I’m not even sure people will want to use these uppercase characters, but I’d like to have them working, just in case. I’m hoping that I won’t have to start from scratch, and that I can accomplish this using the mini version of Glyphs.

I am essentially a complete novice when it comes to typography and font design, so any help or advice would be greatly appreciated!

Do you have ‘top’ anchors in all glyphs?

This looks like the layout engine decomposed the original U+011C LATIN CAPITAL LETTER G WITH CIRCUMFLEX into U+0047 LATIN CAPITAL LETTER G followed by U+0302 COMBINING CIRCUMFLEX ACCENT.